Pasting goes to the wrong instrument?

I have a flow with a piano part. I want to copy the bass notes into the cello part of a different flow.

Here’s what I did:

  1. Select the piano bass clef, cmd-c to copy
  2. Click on the first measure of the cello part in other flow, cmd-v to paste
  3. The notes paste into… the violin part

I’ve managed to get around this by changing to the cello layout and pasting it directly there, which worked. But, it’s slow to switch between instruments as opposed to seeing all of the strings on a single page.

Is there some setting I’m missing for pasting into the selected part?

What version of Dorico are you running? There was a bug in 2.0 but it was fixed…

I don’t know exactly when the bug was fixed but certainly update - the current version is 2.2.10.

I’d say it was fixed somewhere between 2.2.0 and 2.2.10 :slight_smile:

(I tried “check for updates” which led to a 404, but then remembered the Steinberg install center which had the update)


hrm, nope, it worked one time and now it’s back to pasting to the wrong instrument

How are you selecting the piano bass clef stuff?

Well I’m working on a different part now, but seeing the same thing.

In Flow 1:

  1. Click the first measure of the piano part (divisi section 1, treble clef)
  2. Hold shift and click the last measure (all the notes turn orange)
  3. cmd-c to copy

In Flow 2:

  1. Click first measure of clarinet part (it turns orange)
  2. cmd-v to paste
  3. It pastes into the flute part (seems like paste goes into the top-most part in the layout)

It’s weird, I can’t paste it anywhere other than the top-most instrument. After I paste it, it goes to the flute… I cut it all from the flute, paste into clarinet, and it goes back to flute.

Wait a second: divisi section one? Are you using divisi staves on piano?

Yeah, I created a section player and assigned it piano. I use divisi in there to write individual parts. The piano divisi is my sketch, easy to track how many parts are active. I’m really enjoying that workflow for composing, but now I’ve hit a wall trying to copy and paste those parts to other instruments.

I figured it out. I’ve just been highlighting the measure I want to paste into. I need to press to get the caret, and then paste.

You shouldn’t need to, but there’s probably something Dorico doesn’t like with regard to copying from divisi grand staff instruments.

Actually, I’ve just tried this. I have no problem copying and pasting from divisi piano staves, in one flow, to single winds in another flow. And no, I’m not invoking the caret.

Okay if you want to test something out…

Give Flow 2 a time sig of 4/4 and a couple empty measures, (not sure if time sig matters for flow 1). Then click on the now-multi-measure rest, and paste.

What I’m seeing is that if I paste into a single measure, it works. But if it’s a multi-measure rest, the paste goes to the top instrument.

Ah. You didn’t mention multi-measure rests! It’s really really helpful if you can either describe the problem fully (ALL steps taken, not just the ones that you think are relevant), upload a screenshot or preferably upload a project that demonstrates the problem. If you don’t, we end up in these slightly silly situations where it takes 15 posts to say what 1 post could have said.

You can’t really select multirests. They’re not “real” objects; they’re visual representations of absence. Either you’ll need to invoke the caret, or (perhaps more usefully, long-term) you’ll want to turn off the display of multirests in your score layout. You can do that from here:

Make sure you select the correct layout in the right panel, before fiddling with the settings.

Ah, I wasn’t aware that multi-measure rests are visual representation of absence and thus unsuitable as a pasting target :slight_smile:

Thank you for the help! I learned a lot while going through this, and I’m glad we got to the bottom of it.