Patchname field not displayed in the inspector

I’m currently using Cubase 9 elements and I’m struggling to select the sounds with my Pa300 Keyboard.
I’ve downloaded a Pa3X XML file (which is supposed to be compatible with my device) and imported it through the MIDI devices manager.
Unfortunately the Patchname field from which i’m supposed to select the sounds is not there. Instead of it, I have a “Bank selector” and a “Program selector” field. I tried using them to select my sounds but I cannot access to all of them, my keyboard has 2 banks values (MSB and LSB) and only one is available in the inspector (it seems to be the MSB one).

I guess it would be way more convenient to have the patchname field but I’m not sure if this feature is included on the element version of Cubase, should I upgrade to Artist version ? Or is there a way I could change the LSB value through the inspector ?

Did you select the correct midi port in midi track inspector (the midi device you just installed)?

This works fine in Cubase Elements. Create a MIDI track and take a look at the Inspector (to the left). The MIDI input and MIDI output routed to this track are shown here. Click the MIDI output field to make sure that the correct output is selected.

By default it will be called “Korg Pa3x (Korg Pa3x 1 SOUND)”.

If you’re happy with Cubase, I would definitely recommend upgrading to Cubase Artist anyway. It will give you a lot more freedom, and it includes a ton of great effects and synths.

I did select Pa300 on the MIDI input and output. By the way the Pa3X that I’ve installed from the MIDI devices manager doesn’t appear on the possible MIDI outputs, but Cubase still recognize the Pa300.

Open the MIDI Device Manager again. Highlight the Korg Pa3X entry and click the “Output” field at the bottom to assign a MIDI output to this device, otherwise it wont appear in the list of MIDI outputs.

Unfortunately this field is grey and I cannot select anything from it… :cry:

Some screens of my workspace
capture_MIDI_output.png

Click Remove Device, restart Cubase with your keyboard still connected, then import the XML again.

Any difference?

Still grey… :confused:


I’ve got this window when i import the file, should I have any other option ?

The file I downloaded from Korg shows another name:
https://vgy.me/5AGUOz.png

It’s working fine here on both Cubase Pro 9.5.21 and Cubase Elements 9.5.21, even though I don’t have this keyboard.
http://www.korg.com/us/support/download/software/0/307/2470/

Maybe try running Cubase in Safe Start Mode?
https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/safe-start-mode-resetting-the-cubase-preferences.html

Still “Midi Device” … :confused:
Nothing has changed with the other XML file and Safe Start Mode.

I’ve tried running as admin, doesn’t change anything as well.

I think I figured it out. You’re not using the latest version of Cubase Elements 9. Please update it:
https://www.steinberg.net/en/support/downloads/downloads_cubase_elements_9.html

This issue is a bug that got fixed in an update. I should have checked sooner.

Yay ! :smiley: :smiley: :smiley:
It’s working ! Thank you ! :smiley: