PC config, from IDE to AHCI : CD/DVD drive issue...

Hi, all

In another thread (http://www.steinberg.net/forums/viewtopic.php?f=196&t=46699&start=50), there was a discussion about crashes that could occur when closing the C7 MixConsole and I posted an example of it. From which, Fabio Bartolini (a Steinberg support crew member) interviened, asking me to send him the C7 crash dump file. After a discussion via PM, he also asked me for a complete description of my system, using an .nfo file generated by MSInfo32.exe, the Windows system configuration viewer. So, I also did, via e-mail.

The problem is that, using this tool, I stumbled upon the fact that my 2 HDDs were in IDE mode, not AHCI. So, I made few researches on internet which clearly showed that using AHCI is better, especially for intense read/write applications such as audio ones. The disk data transfer rates are reported to be diminished from 10 to 20% and there are much less strain for the disks themselves, due to the way the controller manage the heads movements of them, hence a life duration increased.

So, I realize that I forgot to check this point in the BIOS of my system before installing Windows 7 three years ago on it… Added researches gave me the way to set my controller in AHCI mode in a safe way (it’s a sensible operation : any error can lead to a system refusing to boot…) :

  1. There is a key in the registry to change, and AHCI drivers to install if they are not present. I found, on a Microsoft support page (http://support.microsoft.com/kb/922976/en-us) a patch (MicrosoftFixit50470.msi) doing all this in one pass. Downloaded and installed it. I checked afterward and, indeed, the involved registry key has been modified as it should.

  2. Restarted my system and immediatly went in the BIOS to set my HDD controller to AHCI. Crossed my fingers, rebooted and immediatly stumbled on the following message (before Windows start) :

SATA drive 1 - ATAPI not compatible
Press F1 to resume

Which I did… And everything was normal afterward. Phew ! But since, each time I reboot, I get this message. Of course, I checked how my CD/DVD-ROM drive behaves and everything seems to work : I can copy files from an inserted DVD-ROM and play songs from an audio CD. Didn’t try to burn something, though… FWIW, this drive is a SATA one, labelled as ‘TSSTCorp CDDVDW SH-S223C ATA Device’ (Samsung) and reported to work normally in Windows peripheral manager.

So, after all this, the question is : why does the BIOS keep on displaying this message and how to get rid of it ?

Thanks for any suggestion.

Your optical drive seems not fully compliant in AHCI mode.
On the Asus P7P55D-E you have 3 SATA controllers:
1/ Intel® P55 Express Chipset built-in 6 xSATA 3.0 Gb/s ports,
2/ JMicron® JMB363 PATA and SATA controller including 1 xSATA 3Gb/s port (black)
3/ Marvell® SATA 6Gb/s - 2 x SATA 6.0 Gb/s ports (gray).

My suggestion is to move your SATA Drive to another controller remaining in IDE mode so you’ll have your disks in AHCI mode on one controller and the optical drive in IDE mode on another one.

Assuming that your disks are on the Intel controller (in AHCI), move your optical drive to the JMicron - check in the BIOS that it’s active and in IDE mode.

Hope this helps.

Thanks, Bernard, for your input !

Sadly, I already tried to use the Marvell controller in IDE mode and I got the exactly the same behavior when booting. And the JMicron doesn’t seem to have the IDE mode available. There are only two options : [disabled]/[enabled], with no choice between IDE and AHCI, contrarily to the documentation of the mobo which describes three options as the Marvell one ([disabled]/[IDE]/[AHCI]).

So, I guess that the JMicron controller actualy works with the Intel one : as AHCI mode when the latter is so… But maybe it’s not the case : to be sure of this, I’ll try the JMicron one as soon as I can and report back the result.

Thanks again for the suggestion.

Usually an OS re-install is needed, but Google (switch from ide to ahci?) gives e couple of other fixes.

So, I tried the JMicron controller of my mobo. Result : exactly the same thing as previously. Not a big deal as I found a BIOS setting that allows the system to not halt on this error.

The problem is that I also tried to burn something on three different DVD-RW without success : so, i guess that i’ll have to use my CD/DVD drive only as a reading tool. Not ideal…

enable AHCI
If you don’t want to reinstall (with reference to MS knowledge base Article)

Thanks, but this has already been done, precisely by the MS patch involved (see my first post)…

Sorry Cubic I overlooked,
Regarding AHCI mode for Jmicron I found this on a forum:
Well what do you know, ASUS tech support came through for me! I’ll post the answer here for anyone else who might hit the same issue in future.

Apparently the manual is wrong, there is no AHCI option in BIOS for the JMicron controller

++++
Someone reported success after resetting the bios …
++++
Have you tried the latest Bios: P7P55D-E BIOS 1601: 2013.01.22 update

Hi again, ray

No, but I installed one year ago the one which was released immediatly before it : the 1504. Seems that the 1601 only brings RAID improvements, so I don’t feel like taking the risk for this, unless there are some fixes concerning AHCI hidden in it…