PC hanging after Windows 10 upgrade

Since the free Windows 10 upgrade is about to expire I somewhat reluctantly decided to upgrade from 7 to 10. The number of “no problems here” posts in this thread helped convince me https://www.steinberg.net/forums/viewtopic.php?f=226&t=98663

After the upgrade my PC started hanging 3-5 minutes after booting. Open programs would often, but not always, continue to function. But the Start Menu became unresponsive and attempting to launch any new program failed. So I tried the first 2 of these 3 widely published solutions http://www.pcworld.com/article/3045633/software/3-fixes-for-a-dead-windows-10-start-menu.html These didn’t help. I was reluctant to try the 3rd (reset Windows 10) as that would force me to reinstall all my programs.

Instead I rolled back to Win7 which the upgrade supports for a month after upgrading (I also had a clone of my Win7 system disk which I could have used). I made sure that all my programs and drivers were totally up-to-date, and also uninstalled anything I really didn’t use. Then I performed the upgrade again.

The first thing I did after upgrading was launch Task Manager to the Performance Tab. After a minute or two my SSD System Disk usage spiked to 100% and stayed there while the hang symptoms returned. I found this MS article describing a fix for this problem. https://support.microsoft.com/en-us/kb/3083595

Symptoms
Task Manager shows the disk to be at 100% utilization despite a light or no workload, and the system may experience lag or become unresponsive. In addition, the system event log contains numerous events with Event ID 129, which represent resets of the disk controller.

Initially following the fix described in the article seemed to solve the problem. But after an hour or so the 100% usage returned. Further googling showed that Superfetch can cause this problem http://www.techbout.com/fix-100-disk-usage-error-windows-10-5549/

Disabling Superfetch did help. I’ve been running all afternoon fine. The combination of disabling these 2 features seemed to solve the problem. I wanted to document this in case others experience the same problem.

EDIT

Immediately after posting this I returned to my DAW, and guess what - it’s back :smiling_imp:

I’ll report back after further debugging.

Hi raino.

I’ve had this after upgrading from windows 7. Disk activity 100%.
But to be honest, I don’t know what fixed it in the end. I was going back and forth between windows 7 and 10 several times, using rollback, reset, clean install. That was last August.
Now I’m quite happy with windows 10, even though my computer is not officially supported according to its manufacturer. (Acer laptop, 2011)

If you’re not in rush and have your windows 7 disk image, you may want to try to clean install windows 10 rather than trying to fix this. Starting with a clean system is a good idea anyway.
All sorts of things can go wrong during the upgrade.

I may well try that, although reinstalling everything is unattractive. My bottom line is I can just restore Win7 from my clone and use it. Security updates will continue until 2020. By then I’d likely have a new PC anyway.

Since my OP I’ve tried a number of additional “fixes” to resolve the 100% system disk activity problem. None of them has worked for me. But all of them have worked for other people, so they might work for you if you have this problem. Currently I’m downloading a Win10 iso image to do a clean install.

Here’s the other things I’ve tried:

  • Disabled prefetch using regedit
  • Disabled all Windows notifications using Settings
  • Updated the firmware on the SSD used as a system disk
  • Disabled Windows Search in Computer Managment/Services (type “services” in Start Menu)
  • Disabled Background Intelligent Transfer in Computer Managment/Services

Are you saying that with Windows Search service disabled you still had 100% disk activity?

Did you verify that it actually stayed off? Also, did you rebuild the index from Control Panel>Indexing Options>Advanced>Rebuild?

Yes, 100% with Search disabled - and verified that it stayed off. But I think you are onto something regarding the index. After your post in the other thread I looked at the Properties for my C: drive and unchecked its index option. It spun its wheels for a few minutes accessing every file on the disk, presumably rebuilding the index. Since then, for a couple of hours now, the 100% hasn’t returned. I’m hopeful, but some of the past tweaks have gone several hours working fine only to have the problem reoccur just as I thought it fixed. Still this is encouraging. But it’s going to take an overnight run before declaring victory. None of the articles I’d read suggesting disabling Search had mentioned rebuilding the index, so I hadn’t done that.

Well that didn’t last very long.

Up next, a clean install :unamused:

Ugh.

You can say that again and again and again. That sound you hear in Chicago is me slamming my head against the wall in San Francisco. :cry: :cry: :cry:

Did a clean Win10 install yesterday. Let it run overnight with Task Manager (a constant on my Desktop of late) monitoring the C: drive - all seemed well. This morning I started downloading (5 hours for full C8.5) and installing stuff. Then around 6pm I try to open a pdf but get no response. Glance over at Task Manager and sure enough the C: drive is at 100% :smiling_imp:

Right now I hear Mr. Jack Daniels calling my name. But tomorrow I’ll try doing the tweaks I tried before, because I’m just certain there is a pony in there somewhere and I’ve gone insane (hey lets do the same thing again and expect a different outcome). And when none of that pans out, and it won’t, I’ll clone my way back to Win7.

A thought…

Because your pc is having issues just after startup:

Before doing all those “tweaks” again… take a look at your motherboard website and check if any bios updates are available. Also, some mobo mfg’s have a utility that will scan your pc and offer to update the drivers for all the crap on the mobo. Like chipset drivers, hd controllers, etc. I would do those too.

Good luck and say hi to Mr. Daniels for me.

Regards :sunglasses:

But it’s not just after startup. It can happen anytime between a few minutes after startup to several hours later. In yesterday’s adventure it was 20+ hours after starting - I’d booted the PC the night before and it had run all night & most of the day. Still the mobo suggestion is good.

Jack sez hey!

I’ve officially surrendered and am heading back to Win7. But to add insult to injury, I can’t get Windows to boot from my external Win7 clone disk so I can clone it back to my SSD. Nothing wrong with the image as far as I can tell & it shows up fine in Win10. Windows just refuses to boot from that physical device. So now its at my local repair shop for a few days - hey I’ve already lost a week+ so what’s a bit more. Maybe it’s time to tidy up the studio. :stuck_out_tongue:

What a nightmare :frowning:
I’ve had the 100% Disc usage once on Win10, on the presentation PC in our church.
It was on a HDD, we swapped it out for a SSD and updated some drivers and it’s been smooth sailing since. I wouldn’t know which particular thing made the difference unfortunately.