PC88MX/ Cubase newbie help needed


I’m trying to use my PC88MX through Cubase. I have been unable to figure out how to set it up. I’m using an RC505 looper as my “hub” as per the advice of my music store. I’m certain I have all my connections correct. I bought padshop with Cubase.

My device setup in Cubase is showing generic low latency ASIO driver. I don’t know why it doesn’t show the RC505 driver. I have the latest driver and update for the looper. That part worked.

I also don’t understand how to set up my piano as the controller. I turned local control off, but that didn’t seem to do anything. I’m completely new to this kind of setup, but I didn’t expect it to be this difficult. I really would appreciate any help. I’ve been reading manuals like crazy, but I’m not really getting anywhere. I really want to get set up!


You’ll need an ASIO driver for the RC505. If you can’t select it in Cubase device setup then it seems it didn’t install correctly.

How did you connect your piano to the computer? USB straight from the piano to your PC?

Hi Strophoid,

I think my problem is actually using the RC505 for the interface. It’s keeps going into idle. I’m resetting everything up through the UR44 that I bought. That should work. I’m just going to try again with it. The ASIO driver is showing in Cubase for the RC505, but it will probably go to the driver for the UR44 now, right? I’m going to try again.
I have midi and 2 phono jacks from my piano connected to the UR44, and then through USB from the UR44 to my laptop. I just had to get a power bar to get enough plugs here. I’ll post after I try again. Thanks!

Hi Strophoid,

Okay - I redid everything, and have partial success. My driver for the UR44 installed correctly.
I followed the youtube video Step 1 How to Configure Cubase for 1st Use.
When I got to the test MP3, the song worked through my laptop speaker as well as my big speaker.
Then I was to test my piano. It works through Cubase/laptop, but not through my big speaker. I think this is where I am supposed to make my piano a “slave” to my computer. This I haven’t been able to figure out yet. It says in the manual to put the PC88 on its own MIDI in cable.
Turn MIDI Receive ON on all 16 channels (I’m not sure how to do that. I did the first channel)
Turn the Local Control off - That I did through the Global button.
My sustain pedal on the piano is backwards, and the played notes are stuck on sustain as well.
So, once my piano is going through correctly, then I can worry about my looper. At least I got somewhere.

Ok, glad the UR44 seems to work for you.
I don’t know how much you know about audio and midi so apologies if I insult your intelligence with this :wink:
Here we go:
You want the piano audio to come through your ‘big speakers’. I’m assuming these speakers are connected to the outputs on the UR44, correct?
For now, turn ‘local control’ on your piano to ON. (we’ll turn it off later, but for testing the audio output it’s easier if it’s on, because you can be sure the piano generates sound with local control on)
You say you connected the audio outputs of the piano to the audio inputs on the UR44, which is perfect.

I don’t know which specific getting started video you watched, but below are the basics for setting up audio routing in Cubase:
Open up Cubase and start a new, empty project.
Go to devices–>device setup–>VST sound system and make sure the Steinberg ASIO driver is selected from the dropdown menu.
Next, press F4 to access the VST connections window. Here you can assign the physical in and outputs of your UR44 to in and output busses that Cubase can access. I’m assuming you connected a separate left and right channel from the piano to 2 separate inputs on the UR44. In that case, create a new stereo input bus (if it’s not already there), and assign the 2 inputs you used to connect your piano to it.
Same thing in the output tab of VST connections, assign the outputs you connected your speakers to to a stereo bus. (This is probably already set up correctly by default, but check just to be sure)

With this out of the way, Cubase should be able to access all the in and outputs on your UR44. All that’s left to do, is tell Cubase to output whatever comes in from your piano, to your speakers:
In the project window, create a new stereo audio track. Set the piano input bus you created earlier as the input of this audio track. The output of the track should default to the stereo output bus. If you now press the monitor button (the little speaker icon on the audio track, it turns orange when on), this audio track will send whatever it receives at it’s input straight to the output. So play some notes on your piano, and you should hear them over your speakers.

Let us know if that works out. Once that works, we can get to the MIDI side of things, so you can use your piano as a controller too.

Hi again!

No worries - consider me a complete newbie.

I went through your directions, and the ASIO driver is selected.

I looked in the VST connections and they were in there automatically -
UR44 input 1 and UR44 input 2

and in the outs - UR44 Mix 1L UR44 Mix 1R

I created a new stereo audio track, but I don’t know how to “set the piano input bus created earlier as the input of this audio track.” Can you dumb that down a step more for me?

And, I just turned the local control off, and the piano IS coming through the speaker having gone through the UR44.


Here’s a random pic I took from the internet.
This is a mono track, but it works the same for a stereo track (provided you created a stereo bus, which I can’t tell from your description :wink:)

In the bottom left, where it says ‘mono in’ and ‘stereo out’. Those are the in and output assignments for the selected audio track.