PDF Page size wrong - do I need a printer driver?

I have an ongoing problem I first noticed with Dorico 4… which is when we stopped using a printer at home.

Without a printer driver on my computer, Dorico is getting the dimensions of PDFs a little bit wrong. Layout Options is setting up for Letter Size, but the result of a Graphic export to PDF has too much white space at top and bottom. And I can’t open the Page Setup dialog in Print mode… is that because I have no printer driver installed?

This was never a problem when we had a printer driver. It seems absurd to need a printer driver to export PDFs correctly… but that seems to be what is needed here.

as far as I know, you don’t need a specific printer driver, Dorico handles the graphical export internally.
For PDF export you need to set up the page size in the Layout Options->Page Setup (make sure you select the right Layout). Then in (Print)Export Mode exactly that size will be used for the PDF Export. The other options you see in the right panel in Print/Export mode are not relevant when it comes to PDF Export (they are only relevant if you actually do Print)

I had similar problems on Windows.

First, when you export to PDF is the result of the PDF ok? It often only is the problem that the preview is not the same as the result. So the preview is wrong but the result is Ok.

Second, I made some settings in Windows. In printers and scanners set Microsoft print to PDF your default printer. Then set the properties in the Microsoft print to PDF what you want. A4, Letter or what you prefer. I now have a proper preview A4.

1 Like

I’m marking this as the solution because PDF export is working on my new laptop - but it didn’t on the older one.

There’s still a problem however if Print mode preview is showing the wrong sizing. The exported PDF is correct now, but it’s disconcerting to see the wrong preview size.

I’ll try a print to PDF thing

This was a known issue, but was fixed in Dorico 4.3. What version are you on?

1 Like

Are you on Windows?

You see the right size in engrave mode and write mode. Page view

Mac. And yes those views are correct.

I’m using the latest Dorico 5. The issue doesn’t yet seem to be fixed. Could it be because I’m working on a file first created in D4?

Ok I’m on Windows but I got the right preview when I made the paper size of the default PDF printer the size I wanted in Dorico.

I had most problems with D4 files, maybe they where searching for a printer that was no longer availble on my new computer.