Pedals to Note Length

Hi all,

I’m currently experiencing a problem with the MIDI function “Pedals to Note Length.” On my sequencer (OSX 10.6.8, Cubase 6 build 6.0.3) all the function does is delete the sustain data, but DOES NOT elongate the Midi data written in by my controller.

Any thoughts? I’ve been really frustrated with this one and have tried virtually everything. Any help would be greatly appreciated!!

Hey Boffer

Does it work when you select all the notes first? If I select only the sustain pedal automation points (ie. not the notes) and then do “pedals to note lengths” the pedal data gets deleted but the notes do not increase in length (just like you describe) But if I select the notes first, the command seems to work normally…

Hey Funky Drummer,

Thanks for the response. I see what you’re talking about I just tried that out. The only thing is that no matter whether you select the notes or not, the sustain data gets deleted and the midi notes don’t get elongated. If I don’t select any of the midi data (on another machine where I know it’s working) ALL of the midi data gets elongated and the sustain data disappears. If I select just a few notes, then those are the ones that lengthen when the sustain data goes away.

It doesn’t work whether I select all the notes first or not…

I can’t think of any reason why it would not be working as intended.
Just try temporarily renaming your Cubase 6 Preferences folder (together with any Preferences folders from previous versions of Cubase) so that a new one will be created on next launch.

I know that there’s a Preferences folder under User > Library > Preferences > Cubase 6 but is there another one?

Could it be that your pedal is sending out sustain messages continuously?
The pedal to note length function is designed for sustain pedals that send on and off values thus 1 and 127.
You can use the midi monitor as midi insert and check if your pedal also sends values between 1 and 127.
If so this is the problem. The Pedal to Note Length function cannot work with these type of pedals.

If possible check with the manufacturer of the pedal if you can change the mode to the standard On/Off sustain pedal mode. If this is not possible here is a workaround:

To make the function also work with sustain pedals that send out continuous messages you need to convert the signals to On/Off messages.

With the logical editor -->
1.
Convert all CC64 Value 2 entries that are bigger or equal 64 to 127
2.
Convert all CC64 Value 2 entries that are less 64 to 0

After converting the signals to On/Off messages the Pedals to Note Length function should work.

An attached animated gif shows the problem and then the workaround with the logical editor. I left the logical editor open a bit so you can view how to set the presets up.
PedalsToNoteLenght_Problem_64ContinuousTo64On_Off.gif
Gr,
JHP

(just for interest :wink:… I had considered that… so, to test, I simply reduced all 127 values down to 65, but the function still worked normally, so I rejected the idea.
So, after reading your post, I tried again (same result), then I tried the opposite… I changed all CC#64=0 into CC#64=1, and, sure enough, it no longer worked (even when the “On” value was CC#64=127)!

So, yes, this workaround should do the trick! Thanks for the gif :slight_smile:

CC#64 Reduce.PNG
Better to make settings of Logical editor like that… Will work 100%

Nice idea but are you sure it’s 100%? Isn’t there the chance that you won’t have put you foot down all the way on occasion, say only to 120, so you might unintentionally delete a pedal that you wanted to keep?

JHP’s way looks a bit more certain, to my way of thinking.

It does sound thought that the best thing to do might be to not use continuous sustain mode in Cubase. I can’t get my piano to respond to it in playback, although continuous data is recorded, so it’ll just have to be a live thing. I think recording this data is just making a lot of work for ourselves.

You know, this function appear in Cubase since VST 5/32 version and worked perfect, even when my pedal has bounce of contacts and sent a lot of cc64 00 and cc64 127… Then I faced the problem with this function in Nuendo 3 and guess that it is the bounce’s fault and was right… So if you need just to make this function work you need to reduce the value of cc64 to 0 or to 127 at one moment of time otherwise no need to play with note length :slight_smile:.