Percussion channel not responding

The Timbales channel in the attached project is not working correctly for me.

I can’t adjust the velocity of the notes and the fader in the mixer doesn’t change the volume. I’ve tried creating a new player as well as reseting the playback template. Edit: if I change the playback template to Silent, the velocity becomes editable.

Does anyone have any suggestions or insights?

Timbales.dorico (803.4 KB)

The timbales are two instruments. You can change the velocity or use the fader for the Timbales 1 (orange) or Timbales 2 (yellow). To see them in the midi editor correctly, you need to expand the Timbales (red) in play mode.

Thanks for the info @Nukkul.

I’m sorry but I don’t know what you mean. I can’t see where to click to expand?

Now you see them in the key editor

This is not visible on my end.

woops. Yes, it’s not there in Dorico 4.

If you choose “show midi” in the mixer you at least see the additional faders.

How to modify the velocity, i don’t konw.

Yes, although they still don’t change the sound at all.

I did have Congas and Agogos that worked fine from memory although now that I create a new project, the Congas display the same problem.


hmm. I can change the dynamics with Timbales 1 & 2. The red Timbales doesn’t do anything, as i mentioned before.

I’ll just send you a list of all the edits I want in my Latin percussion velocities lol

As Jonny Bairstow would say: I’m stumped.

I guess it’s this (from the Version History):

Routing for percussion kit components. Each individual unpitched percussion instrument included in a percussion kit now appears as a separate track in the track overview in Play mode, making it possible to select each instrument and change the settings in the Routing section of the track inspector panel independently.
This restores functionality that was present in versions of Dorico up to 3.5 that was temporarily removed as a consequence of the rebuilding of Play mode in Dorico 4, allowing each instrument in a percussion kit to be routed to a different endpoint if necessary.

1 Like

It is related but it doesn’t explain why I would be able to edit note velocities and adjust VST faders correctly on the Congas and the Drums: both of which contain 2+ instruments. (I just opened my original project to check).

The fact that the velocities snap to zero indicates that there’s a problem with the routing of those instruments. I’ll need a bit more time to look into this, as this stuff is all a bit complicated, so I’ll come back to this when I can.

In the meantime, you can edit the velocities using the Velocity property in the Properties panel.

Thanks Daniel, I appreciate it.

Ok. I guess I’m getting closer.

(Everthing is referring to your cutdown version)

If you check in Play Mode the Endpoint Setup of the Timbales:
Timbales are Channel 1
Timbales 1 are Channel 2
Timbales 2 are Channel 3.

In the Halion Player:
Channel 1 is Latin Percussion
Channel 2&3 are [GM 129] Stereo GM Kit

This seems to be the standard for Timbales, even if you create a new project. Bongos are only [GM 129] Stereo GM Kit
The Latin Percussion isn’t used by the Timbales, you hear. But it belongs to the Fader and the velocity in the Key Editor.

Simple fix
Assign the Timbales to a [GM 129] Stereo GM Kit and you have a working Fader and can edit the velocity.

Why it is like this? I don’t know.

Interestingly enough, if you switch to Channel 2 and back to Channel 1, the Timbales will use the Latin Percussion but of course with wrong sounds.

Basically Dorico will always assign the GM kit even when it doesn’t need to, and this can create issues. This is something we know needs to be addressed, and it’s on the backlog.

I can’t seem to get it to work with these instructions at a glance, and I don’t really have the time to try too hard.

Thanks so much for your help though.

Ok. no problem. Different solution. I found the Timbales sounds in the Latin Percussions.

Go to
Library > Percussion Maps choose HSSE Latin Percussion click on Show all

Now add the Timbales like in this picture.

Reload the Playback Template:
Play > Playback Template… > Apply and Close

Now it should work.

Hi @dspreadbury ,

If you do get a chance to look into this more at some stage: Dorico 4 has been semi-regularly not playing back and then hanging on the Audio Engine when reopening the program. Upon Force Quitting the program and the VST Audio Engine, the project usually loads as expected.

This has only happened since I started fooling around with the Timbales routing etc. trying to solve the problem at the beginning of the thread.

Diagnostics and Spindump attached. (VST Audio Engine said “not responding” in the Activity Monitor.

Dorico Diagnostics (1.7 MB)
Spindump (269.3 KB)

EDIT: and another set from today (I’ll stop now!):
Spindump (288.9 KB)
Dorico Diagnostics (2.1 MB)