Percussion Input via MIDI Keyboard

Hello,

I’m still new to Dorico and trying to figure out some of the basics. Right now I’m stuck with inputting different playing techniques for percussion instruments using a MIDI keyboard.

I’ve set up all of the used articulations by the VST as playing techniques for the instrument in the Setup mode and they appear in Write mode just fine.

I also created a percussion map for this instrument linking the playing techniques to pitches.

What I expected is, that recording the note E3 on my MIDI keyboard will automatically put this note in the “Rim shot” lane, displayed in the MIDI editor. But instead, the note gets put into the regular “Snare Drum” lane with the Natural playing technique and therefore plays back the wrong articulation. Am I doing something wrong or is this just not how things work? Do I have to manually put the note into the right lange?

Here are my preferences for percussion input:

I suspect you need to adjust the value of Input techniques from MIDI key, since MIDI note 48 is C3, i.e. the C below middle C (MIDI note 60). Try setting that value to something like 12, which will move it a lot further down the keyboard.

Unfortunately all notes are still placed in the “Snare Drum” lane with the “Natural” playing technique.

Is my assumption even right, that depending on the notes played on the MIDI keyboard, they should automatically be assigned to the lane with the corresponding playing technique?

Yes, absolutely it is. Perhaps you could attach the project in which you’ve defined your percussion map, so we can take a look and see exactly how things are configured?

Here you go:
Score.dorico (892.6 KB)

Thanks for providing this project. There’s a bug here that is preventing the mapping of MIDI notes to percussion playing techniques for single-line percussion instruments that are not part of a percussion kit. I will make sure this gets fixed. Sorry for the inconvenience in the meantime!

You could add your snare drum instrument to a kit, so that the kit has only one instrument in it, and that should allow MIDI input to work for now.

1 Like

Thanks for looking into this and providing a workaround for now. Looking forward to an update with a fix.

Hallo @dspreadbury,
There is always the same problem with recording a percussion kit or the playing techniques disappear after loading in another project.
I’m just saying that.

Just installed the new update 4.3 and unfortunately this bug still exists :confused:

It shouldn’t do: the problem as reported was fixed (I did it myself!). Does the exact same project that you uploaded in August still exhibit the same problem for you? If so, we’ll need to try to figure out how and why that might be.

Yes, it’s the very same project (my template). When I opened it with 4.3 it was automatically converted to 4.3, but still all inputed notes from my keyboard get assigned the natural playing technique.

EDIT: I even tried an empty new project and did everything from scratch to test it. But still the notes don’t get assigned the right playing technique. Maybe I’m setting up something wrong after all?

OK, I will take another look as soon as I get a chance. Things are always a little hectic after a new release, so I ask for your patience until I have time to dig into this once more.