Percussion kit: Omitting rests works only sometimes

Good morning, everybody :slight_smile:

I have a percussion kit consisting of a concert drum (voice 1, stems down) and cymbals (voice 1, stems up).
In Flow options I have chosen to hide rests when only one of the instruments is playing:

grafik

The result is somewhat dubious though:

grafik

In the first two bars of the screenshot it works perfectly, from bar 5 on it doesn’t work. Later, from letter B on it works again, only to fall back to “not working” a few bars later. And this goes on through the whole piece. Sometimes it works, sometimes it doesn’t.

I checked that there are no forced rests or other $stuff going on, this also has not been an XML import, it was put in directly into Dorico.

Is there some setting I am missing or other things I can do (besides hiding them manually via “Hide rests”, of course)?

Thanks! :slight_smile:

This option controls the padding at the start of the voice, i.e. before the first note appears, and at the end of the voice, i.e. after the last note. Once a voice has started, the voice will be padded. That’s what you’re seeing in e.g. bars 1 and 2, where the upper voice has not yet started, so no rests appear, but from bar 5, the voice has started with notes in bars 3 and 4, so the voice continues to be padded thereafter. Without seeing the project I can’t tell you why things look different at rehearsal mark B.

Hi, Daniel!

Thanks for your explanation. I will send you the file or try to come up with a tiny example that exhibits the behaviour. (But like I said, it’s only 2 instruments on this kit, nothing special going on as far as I can tell.)

I went through some of my latest compositions to find material along the same lines and found many other examples where this sometimes works and sometimes does not - and it definitely changes within the piece (it’s only a single flow). Since I often have players that combine concert drum and cymbals (wind music with marches, right? :wink: ) the topic comes op in almost every piece:

grafik

From what I found, my best guess would be that downstem voice 1 is allowed to omit its rest when not playing, while upstem voice 1 always creates rests…

But no matter the reasons for the curent behaviour, may I add this as a feature request then?
When combining several percussion instruments into a 5-line-staff, omitting these bar rests when only 1 instrument is playing can really help to declutter those staves. When only the concert drum is playing for 50 bars, there is no need to render a page full of bar rests for the cymbals. And when there’s only bongos drumming along, the triangle voice does not need rests the whole time.

Thank you! :slight_smile:

Hi again.
Here is a tiny example:
percussion-rests.dorico (497.5 KB)
Fresh Dorico file created from scratch, a single player with a kit consisting of two drums, the upper one having its stems up, the lower one having its stems down.

  1. Daniel, you are perfectly right that the option I used only is responsible for the very first measure here.
  2. My guess has been reassured that upstem voice 1 always creates rests while downstem voice 1 does not. (Which seems perfectly reasonable for regular players, with upstem voice 1 being the “main” voice. With percussion players on the other hand, there is no such differentiation, I guess.)

grafik

The voices that are not padded with rests in Percussion are called extra voices. Not sure you can only use those, but they could somehow help you…

Hi, @MarcLarcher !

Thanks for sharing your idea! I played around a bit with this, but never got usable results: When I change only some of the upper notes to an extra upstem voice, the questionable rests still prevail; and when I change all of them to the extra voice, all rests are gone, even those within a single bar that are needed. :man_shrugging:

1 Like