Percussion Layout missing staff names?

I have 3 questions:

  1. I’m looking at my Percussion part and I’m not seeing any of the staff names labeled. Any reason why?
  2. How do I include all the instrument names in addition to the Percussion All part name?
  3. How do I condense the instruments in the part to hide the ones not being used? I created condensing groups in the layout but I don’t see them in the list

For #1, Go to Layout options, Staves and Systems, enable Staff labels on first system.

For #2, you could add a text frame to the layout to add their names in the upper left under “Percussion All”. If you are using a 5-line staff (not likely with the number of instruments you are using), you could generate a legend for all instruments by right-clicking the staff and selecting Percussion/Legend for All Instruments, then drag this using Engrave Mode to the upper left corner.

For #3, did you go to Engrave Mode, Players/Condensing and enable condensing for Percussion All? I know that you can hide staves in Layout Options, Vertical Spacing/Staff Visibility if that’s what you need.

Great thanks! I wasn’t aware for #1 and #3 they were per layout options for them I had to reapply for the parts.

#2 okay, I was wondering if I needed a text frame. Anyway I can use tags to reference instrument names instead of hardcoding in instrument names?

#3 Thanks for the staff visibility suggestion. That was actually what I was looking for compared to condensing. How do I add hoc hide or unhide certain staves when needed to override this global option?

Yes, I forgot you can use a token for listing out the instruments, as I did for an earlier project.

Screen Shot 2023-05-09 at 4.08.25 PM

Screen Shot 2023-05-09 at 4.08.36 PM

Thanks! Anyway to filter the instrument by flow? I getting the full list when instruments aren’t included in that flow