Percussion noteheads don't survive flow import

Hi there, I hope all are keeping safe and well. I’m having a little problem with importing a flow to a new project, I wonder if anyone could help me with it. This is with Dorico Elements 3.1.10.

The problem is, I’ve got a flow that uses percussion kits that I’ve edited to add playing techniques and noteheads corresponding to those playing techniques. However, when I import the flow into a new project, it keeps the playing techniques but loses the noteheads.

I’ve tried this two ways:

First method: just import the flow directly into a new project. In this case, I don’t have the percussion techniques that I’ve mapped, and not too surprisingly, don’t have the noteheads either.

Second method: export the modified percussion kits from the first file, and import them into a new file. I also added the unmodified instruments, and made sure the players and their instruments were listed in the same order as the original file. Then import the flow using the “merge players where possible” option. The result here is that it merges the unmodified players, but creates new players for the ones where I imported the kits, with the same result as the first method, because the new ones rather obviously don’t have the imported kits. The techniques are there but no noteheads.

Am I doing something wrong? Can anyone help? Thank you very much!

I imagine I can work around this by copying my original project and deleting the flows I don’t want, but I’d like to do it properly, as that method may not always be an option.

If different flows use different percussion kits, have you tried combining the kits into one layout for the players and either letting the layouts hide the empty staves of the kits that do not play in each flow or deactivating appropriate flows for the combined percussion layout?

It would sure beat copying one kit to the other if there is any extensive amount of music involved.

Hi Derrek, thanks for your reply.

I’m not sure I understand your suggestion though, sorry! Probably me just being a noob. Everything is ok in my one project file, and I have turned players/percussion kits on and off in the flows therein, but it’s getting a flow out of that project file and into another one that’s tripping me up.

Perhaps it would help if I explained why I’m trying to do this: I’ve got a project file which I’ve used as a “sketchbook” if you will, so it’s got lots of sketches, experiments, and then one flow that’s the final piece. I want to keep the sketches (because I’m that way) but I want to move the completed piece into a new project file where it will be joined by other completed pieces, eventually. That’s the motivation, as they say in method acting. :smiley:

I was under the impression that I would be able to export the percussion kits with my edits, and import them into a new project and then import the flow also into the new project and keep everything the way it was in the original project. But it loses information in that process. Why isn’t that working for me? Any ideas?

In particular, I’m puzzled by why the imported percussion kits won’t merge with the ones from the imported flow - they were exported from the same place that the flow is coming from, so shouldn’t they be able to merge?


I think your expectation is absolutely correct, elenmirie, but I’m afraid there is a missing piece or two here that is going to make your preferred workflow impractical. Although changes you make to the percussion kit themselves are currently imported when you import a flow into a new project, changes to percussion playing techniques are not yet imported, and along with them any new notehead types you have defined. This is an oversight, basically, and something we need to correct.

Fortunately in the specific case you’re talking about now, this isn’t a practical problem: do File > Save As to save your current project with its sketch material and the final piece under a new name, then delete the sketch flows etc. to leave only the final flow behind.

One more thing that is worth considering: you don’t actually need to remove those sketch flows at all. Simply select the ‘Full score’ layout and any part layouts you are relying on in the Layouts panel in Setup mode, and uncheck the checkboxes for each sketch flow in the Flows panel. The sketch flows will all remain safely saved in your project, but they won’t appear in your performing materials.

Okay, Daniel, thanks for that. I’ll work around it; glad I found that out now before I dig myself in any deeper! :smiley: Thanks for that tip about managing flows, too, that will come in handy.