Percussions: what am I doing wrong?

So… As far as I understand Dorico is supposed to make life considerably easier by doing most things automatically. However, when trying to create percussion parts I’m having a hell of a time… I basically have three questions:

1.- My score has two percussion players that play multiple instruments, so in Setup mode I created two instruments called Percussion 1 and Percussion 2 respectively and added all the instruments that each player would perform, thus this example of percussion 1:


But when I go to print the page it looks like this:

Aside from the obvious problem of text overlapping the biggest issue is that it’s incomprehensible and inaccurate. The first quaver, as can be seen in galley view, is supposed to be a snare drum, but there’s no indication in the score and where it says “To Tambourine” that’s already supposed to be the tambourine. So what am I doing wrong and how can I fix this?

2.- inputting seems tediously slow, which makes me think I’m not getting it. I’ve read everything I could find on the subject (this forum, Dorico’s videos and the manual) and what I’ve gathered is that you double click on the bar (or SHIFT+N), use the arrows to select the appropriate instrument/drum, use the numbers to select length, letter Y to input and (,) + Y for rests. In such a modern and progressive software I cannot believe that I need that many procedures just to input a simple kit. In the past, in a software whose name will not be mentioned, it was as simple as keeping one hand on the number pad and the other one on the MIDI keyboard: kits are selected by pitches on the MIDI keyboard, lengths by the Number Pad and rests by simply pressing the 0 on the pad and the length of the rest is equal to whatever rhythm length is selected at that point. So that’s 5/8 clicks/presses (depending on how far the next kit is) versus 3 in the other program or 6/9 versus 3 for rests. I’ve tried setting the MIDI input to map but it doesn’t input anything i.e. I still have to press the Y key and then it inputs the map, but not the rests i.e. if I press the (,) then I have to again press Y to input the rest. Am I doing something wrong or is this the way it’s meant to work? Seems very convoluted… At least Dorico should start inputting the second I press down on a MIDI key and if I select Rest (,) it should just write in the rest, right? I shouldn’t have to press Y yet again.

3.- Percussion cues. So it appears I can only put in a cue from another percussion instrument of the same amount of lines. Is there a work around? I basically need to give the two percussionists the opening line from the trumpet so that they know when to come in. I’ve tried pasting a cue, nothing happens, I tried adding an ossia above, nothing happens… Do I perhaps need to add a trumpet to the percussion player?

Many thanks for any help!

The unpitched perc instruments should be in a kit and then grouped in the same Player as the pitched percussion (Xylophone).

perc.png

I’m not sure I understand your objections to the input method for percussion: showing and/or positioning the caret and choosing the note value are of course exactly the same for both percussion and pitched instruments. The only difference is that because the pitches don’t mean anything, you can either use the caret to choose the instrument and then input a note on your MIDI keyboard (or hit Y) to input a note on that specific instrument rather than at a particular pitch. Dorico doesn’t treat percussion kits as kit instruments because they’re not pitched. If you can learn the MIDI note numbers required to produce the sound you want then you can use the options in Preferences to input using those pitches instead of the nominal staff positions for either a treble or bass clef.

You can’t cue a pitched instrument onto an unpitched instrument at the moment, I’m afraid. This is a limitation that is quite difficult to get around just now. If you’re able to work with a rhythmic cue rather than a pitched one, then you can paste a cue event that you’ve created on another instrument onto the percussion kit, but it has to display as a rhythmic cue only.

Ah of course! I knew I was making a mistake… Bad habits from previous programs! Thank you very much!

My dear Daniel, I’m sorry you interpreted my post as an “objection”, but as I stated in the title I believe I’m doing something wrong and in fact partly I was! But I think there’s either a bug or one thing that doesn’t make sense:

1.- First of all, yes I was actually making a mistake because I hadn’t realised that the Mapping was actually two octaves below from where I was playing, that’s why nothing was inputting when I was hitting the MIDI keyboard.

2.- There’s still the problem, which I don’t know if it’s a bug or not, which is if I’m inputting via MIDI keyboard (using the “Use percussion map” option) and I press the (,) to get a rest Dorico doesn’t write it unless I press the Y again. So again, if this is a bug I’m reporting it, if it’s not could I please request this as a feature? Otherwise it makes no sense to have to move my hand away from the Number Pad every time I have to input a rest… Simpler if I can just press any of the MIDI keyboard and Dorico writes the appropriate rest according to the rhythm selected.

Thank you and be well!

The rest thing isn’t a bug, it’s a feature. You’re still expecting Dorico to work like Sibelius. “,” engages rest entry mode, it doesn’t actually notate rests. Unless you’re doing something unusual with force duration you shouldn’t need to enter rests in Dorico at all. Just use the arrow keys or space bar to navigate through the existing music (or rests) and then type notes when you want them. Dorico will figure out the rests automatically.

Leo’s correct with regard to how we have designed rest input to work. You may find that moving your hand away from the number pad to hit Space is easier than hitting , on the pad and then Y on the main keyboard since the Space bar is a bigger target, and you also save a key press. In general you do not need to input rests in Dorico – this is one of the great advantages of its input method.

OK, I believe we’re misunderstanding each other. Please ignore everything from the first post as I now know most of them were mistakes on my part.

I’ve remapped the rest shortcut (,) to the NUMPAD (0), dotted to the NUMPAD (.) and tie to NUMPAD (+) so that I can input everything from the NUMPAD with one hand and the other hand in the MIDI keyboard. When I write pitches on a pitched instrument, if I press on the Rest shortcut and press a note on the MIDI keyboard the caret advances the duration of whatever rhythm is selected. It’s great and I can go superfast, especially if I input things like a minim on an upbeat to quickly create a quaver tied to a dotted crotchet on a 6/8 for example. This procedure however, does not work for percussion instruments (at least the unpitched ones).

So what I’m saying or asking or requesting is that if I press down on the rest shortcut, whatever that may be, and then I press on a MIDI Keyboard note it would be very useful for the caret to MOVE (not write) whatever rhythm duration is selected, exactly the same way as pitched instruments do.

thank you!

Right, I’m with you. I’ll need to try this out but it sounds like an oversight in the note input code, in which case we will need to fix it.

Well I found a solution but found another issue…

The solution was so simple I feel like a fool. Basically instead of having the rests in the NUMPAD (0) I put the spacebar (move caret) there and this behaves closer to what I expect i.e. the caret moves the amount that is selected in the rhythm duration. This was inspired by your post…

The issue, now that I have things working consistently between pitched and unpitched instruments I found that instruments like congas and other two line percussion’s like these do not obey the follow mapping input. So for example, if I have a 5 line toms I can input this as easily as a pitched instrument, one hand on the NUMPAD and the other one on the MIDI keyboard, the appropriate drum is selected by the appropriate key on the MIDI keyboard. But on two lines, say I have a conga high (quinto) on C and low (tumba) on D, Dorico will only input on the line I’ve selected. So if I select the top line (quinto) and I press D I still get only the Quinto. Furthermore, it appears I can just press any key and I just get the quinto. If I want the Tumba I have to go to the arrows and move to the next line.

Again, I might be doing something wrong (wrong mapping, kit vs instrument, etc) but inconsistent behaviours like these really slow you down…

No, I don’t think you’re doing anything wrong. What I suggest you do for the time being is set your e.g. two-line conga kit to display as a five-line staff in Layout Options. Then you can input using staff position. If you think about it, it makes sense that you can’t do this when you’re looking at it as a pair of single-line instruments positioned close together, because those single lines don’t correspond to a specific pitch, whereas on a five-line staff Dorico can interpret it either using the G or F clefs.

Ah that’s interesting, but then I’ll end up with the wrong notation system… Or are you suggesting I change it back after I finish writing?

Yes, of course :slight_smile:

Right, fair enough…

why is only vibra shown in page view although I disabled ‘hide empty staves’’ please?


Peer, see https://steinberg.help/dorico_pro/v3/en/dorico/topics/setup_mode/setup_mode_layouts_instrument_changes_allowing_disallowing_t.html
If you allow instrument changes, you give Dorico the right to use as few staves as possible for each player.

Perfect – easily solved. Thanx Leo !