Performance maxing out in Cubase SPM despite hardware benching <30%

Curious about how performance/metrics work with VSTs and Kontakt here. My goal is to be able to use as many un-frozen tracks concurrently as I can.

https://imgur.com/a/3VBUME3

According to the Cubase System Performance Meter (near bottom), I am maxed out; when I press play the audio will fail pretty soon. Ok, makes sense. This is with all tracks unfrozen and plenty of Kontakt/native VST/some audio loaded.

A hardware monitoring tool I use called NZXTcam (comes with my water cooling system) reports that I’m using a relatively low percentage of full capacity however. Windows performance monitor (when hitting Windows-G) reports similarly.

Curious what might be at play here then. Am I not utilizing my full hardware? I recently upgraded to i9-9960x/NVMe/64GB/Presonus Quantum in the hopes of running as expansive projects as possible. Performance has generally been good but I hope I’m not leaving performance on the table somehow. Freezing does not solve everything, as I often process on group busses, and if I need to overhaul the structure of the piece I of course need to un- and re-freeze everything.

Appreciate any insight!

The cubase performance meter is not measuring total system cpu utilization like your other meter, so there will often be little correlation between them. It is showing the amount of the available time slice required to process a block. All it takes is one thread to be the long pole in the tent to max that out. As for what to do about it, the usual advice applies: take measures to spread the load across cores (use synths monotimbrally, avoid bussing that routes all processing through a single thread, etc), change your buffer size, use asio guard, etc.

What GHz is your system running at? Cores matter, but perhaps the GHz may matter at least as much, if not more. All of GlennO comments are valid as well

If you use Windows Resource Monitor you can see the load on each core.

Consider - if half your cores were totally maxed and the other half totally unused you’d be having performance problems even though in total you are only using 50% of your CPU.

I’ll give you a few general pointers to consider. Most performance issues can solved for the greater part by doing these.

  1. When mixing latency doesn’t really matter. So for this use large buffer sizes (1024, 2048). When recording use buffer sizes as low as you need to go to lower the latency and get a the response you need and feels comfortable (256…128…64). Obviously it differs if you’re recording a lush synth pad v.s. piano or other percussion parts?
  2. Make sure you are using a high performance power profile in Windows. As a quick fix open menu item Studio > Studio Setup > VST Audio System and enable ‘Activate Steinberg Audio Power Scheme’ and make sure “Activate Multi Processing’ is also enabled. Optionally you can also enable ‘Activate ASIO-Guard’.

After doing the above you should already see a considerable improvement? If not you may have to dig deeper and tweak your bios and maybe other settings within Windows?

This one and most other audio related forums are paved with such advice. So you should be able to find more information on this if needed?

Hope this will point you in the right direction?