Performance Meter issues

Hi this is a video without any project loaded
64Gig I9 :frowning_face:

Try to move your mouse around rapidly inside Cubase.
You’ll see the meters drastically drop.

This is called dynamic clock, which is a feature of your CPU.
When there is no load, the CPU frequency is reduced, that is why the meters increase.
But when there is load, the meters will drop, because it will work faster.

If that doesn’t please you, then you can switch to the High Performance mode under Windows power plan settings. That will cause the CPU to work at maximum speed constantly, and the electricity bills will also reflect this.

Steinberg used to strongly recommend that you turn off all the dynamic clocking settings in BIOS to avoid problems.

Is this no longer the case with modern CPUs/Cubase12? And if so, from which CPU and Cubase generation did the advice change?

Regards,

When did Steinberg use to say that ? 15 years ago ?
The old EIST was since replaced with Speed Shift which is much more faster and completely transparent.
And also Cubase is one of these programs that make great use of it, if not the best.
So, really, there is no reason to make the CPU run at full speed 100% of the time, we are no longer in the early 2000’s…
Such a thing is no longer a problem with 14 nm and lower CPUs. The number of transistors and working frequency is so much higher compared to CPUs from 10-15 years ago, that dynamic clock no longer causes performance issues with audio production, really.

Full post here

That information was still being promoted on their web site within the most recent few years and people were regularly pointed to it if they had performance issues.

Not everyone is running the latest gen hardware or software so the info remains valid.

Just curious about your build, do you have any monitoring software, RGB hardware (fans, ram, keyboard, mouse, etc) and USB controlled fans and their associated control software, or more generally (not related to the RGB stuff), any “junk” or obscure programs like third party anti-virus and other things that may seem out of place for a “clean” build, running in the background ?

I myself have a RGB build which is good for gaming and rendering, but when it comes to using Cubase, it makes some performance spikes when it idles and there is no load (these spikes are nothing out of the ordinary), but under load (even at very low load) we don’t “see” these spikes anymore. So setting the CPU at max speed wouldn’t really change anything.
These littles peaks from time to time do not prevent me to work on a DAW at all.
I’ve never experienced any audio dropouts, wether the CPU clock is moving or not.

To be sure, is your video in the first post with or without dynamic clock ?

Just interesting. What is the dynamic clock in BIOS? Really don’t know :slight_smile:

And here we go. Current information from the Steinberg website on how to set up your computer for Cubase. So is this information still current? And on what version of CPU and Cubase?

Taken from: https://helpcenter.steinberg.de/hc/en-us/articles/360008589880-Windows-How-to-set-up-and-optimize-a-Digital-Audio-Workstation

"Tweaking the computer

Modern systems with a fully updated Windows should not need any of the default settings to be modified. However, if certain drivers are not fully optimized and you experience audio drop-outs, it is worth having a closer look. Note that the following settings are often not accessible, especially on laptop systems.

  • Disable Hyper-Threading (Intel)/Simultaneous Multi-Threading (AMD) in the UEFI BIOS if your CPU supports it and if your BIOS allows you to modify this setting.
  • Disable advanced power-saving and dynamic performance options for your CPU if applicable. This usually needs to be done in the UEFI BIOS of your computer and includes ‘Enhanced Intel SpeedStep (EIST)’, ‘AMD Cool ‘n’ Quiet’, ‘Intel Turbo Boost’, and ‘AMD Turbo CORE’.
  • Disable C-States in the UEFI BIOS if this is accessible. C-States allow your CPU to sleep when idle, which may interfere with real-time applications such as audio. This option is often called ‘Disable CPU Idle State for Power Saving’."

:face_with_monocle:


Are your drivers not optimized ?

Mine are well optimized, since I only use high quality hardware and software, and have as few programs running in the background as possible, so disabling these features would not change anything in my case. Everything is running flawlessly.
I’ve tried it already, in case you’re wondering.

But still, you did not answer my questions.

I am away from home at tue moment but it is a I 9 the one that is specifically for single core performance 64 gig of ram and an nvidia card
Cstates turned of hyper threading turned off, it is only since the last 2 versions, Do not have issues with studio one 5, Use an Apollo X 6

I go back to the first post with the video, there was nothing loaded so should not be that activity, And when there is a project loaded there is no change ie the activity does not reduce or get worse