Performance Spikes with Frequency EQ in Cubase 9

Was just working on a project for most of the day, and then noticed later on that I was getting large spikes in the performance meter (average load) especially when starting playback from different points along the timeline. I had never had such spikes in Cubase8/8.5 before. I then loaded a few other projects in Cubase 9, only to find that the meter was running fine with no spikes. After returning to the original project as still getting the spikes again, I disabled all plugins, and the performance went back to normal. This seemed odd since most of these plugins (3rd party) were used in the other projects as well. The only plugin that was new to this project was the Frequency EQ that comes with the new Cubase 9. After disabling it, everything was fine again, even with the 3rd party plugins.

I tested on (2) internal drives and (2) OSX systems loaded with the exact same results. Upon further testing, I found that it has to do with when the Frequency EQ plugin is automated on tracks. If you either disable the Frequency EQ plugin, or disable the automation of it, everything is fine. Turn both the plugin(s)and their automation back on and performance meter starts piking again. The more instances of Frequency EQ plugin and automation you have on tracks in your session, the worse it seems to get.

Needless to say that all along I thought it might be one of my third party plugins. But for Cubase 9’s own EQ that comes with the program to be causing these issues is pretty bad. Hopefully since the program is fairly new, it will be worked out shortly.

Do you have the Linear Phase turned on?
Linear Phase is a big resource consumer in any EQ that offers it.

No. Linear phase is turned off by default for each channel. I have not even tried using linear phase mode as of yet. Didi more testing last night. Definitely an issue with the Frequency plugin. Have not seen this with any third party plugins as of yet, even with automation used. I bounced down the tracks using the Frequency plugin as new audio and deleted all the old tracks. No more spikes so far. Performance meter seems to be running as normal again, even with the 3rd party plugins still on the other tracks. So far I can only reproduce this issue when using the new Frequency EQ plugin automated on tracks within a project. If anything changes, I’ll post new. Waiting to hear a response from Steinberg as well on this .

I’ve been thinking about this for a while. When you say spikes, do you mean the red light turning on? Or are you getting actual audio glitches and drop outs when that red light comes on? This is quiet important because unless you are experiencing glitches and drop outs then the red light is neither here nor there. In fact, the showing of the red light is common place. Just take a look at some of the tutorials on you tube or elsewhere. You’ll be hard put to find one without the red led glowing.

Glitches and drop outs however are a different matter. So which is it?

The majority of time the green bar starts spiking up, some times quite high, sometimes hits the red. Occasionally got some glitches and drops outs depending on what I was doing at the moment. Mostly unusual meter spikes and usage though. Keep in mind I am referring to the ‘average load’. I’m not sure what you mean when you say the showing of the red light in the performance meter is quite common? The average load should almost never spike up that high, especially not hitting the red. I have never seen this before (and I do large orchestral mockups in Cubase). Been using Cubase for many years now and many versions. Even under Cubase 9, once I removed all instances of the Frequency EQ plugin, no spikes at all, especially none hitting the red. The only meter that ever really spikes up occasionally is the disk meter when starting and stopping playback which doesn’t effect performance. Again, if the average load meter is running very high or spiking in the red too often, I’d say its time for a new computer.

I think the red overload light on the asio meter is not necessarily accurate. I also have used Cubase for years, and have never had the overload red come on until some point during 8.5. The red light would come on, without anything playing, and without causing any audio artefacts. If I clicked on it to reset, it would come back straight away, without anything playing. This is probably one example of many of why users take the red overload with a pinch of salt - sometimes it may be accurately representing something, but many of us know that sometimes it has no bearing on reality.


Hi km08,

Could you please create a new project, just insert and automate Frequency and see, if the peaks show up again ?
And if so, is it possilbe to upload or pm me the project ? What sampling rate, ASIO buffer block size do you use ?
The 96 dB cut filters can be pretty heavy on the processing side, especially when using small buffer sizes.


I created a few new projects and can reproduce it on all of them. This is not a project specific issue so I don’t have any specific project to send. Also, it seems to be worse the more tracks and audio you have imported into the project. I always use 44.1 sampling rate and have audio buffer size set to 512 for my MR816x audio interface. In fact, I’ve been using the same basic settings for some years now with any plugins including third party without performance issues. I’m running a Mac Pro desktop with (4) internal drives, one for system/apps and another for audio.