Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

I see you did you test on Logic Pro X 10.4.4.
Any chance you could run your test on Logic Pro X 10.4.5 to see if it’s the new version that provides better performance?

Better performance than what? Anyway, I get the same result with 10.4.5. I’ve gotten the same result with various versions of LPX going back quite a ways. This is just further evidence that the DAW has very little influence on the performance of plugins. Why anyone would think it does is a mystery to me.

You seem to be obsessed that the only thing affecting a DAWs performance is plug ins. We already identified in this thread that it’s the disk read over loads that are showing the issue in C10 on my system. Look at the performance meters in Studio One and Logic which have no issues compared to the performance meter of Cubase 10s.

The point once again is that C 10s performance ( including disk performance ) is not as efficient as the other 2 DAWs when considering optimizing all possible settings in each DAW.

Hi All

I can’t help but wonder why people spend so much time playing around with things like this instead of making music.

Best Regards, Dave

BTW. Performance meters are highly unreliable, you can’t compare performance using those.
Fill up with plugins until I starts to crackle, then back off until the audio is stable.
Make sure no track is armed for recording,

Obviously I’m experiencing disk overloads which is affecting C10s performance.

It’s a pretty reasonable question to ask when compared to the performance of the 2 other DAWs.which do not experience disk over loads using the same audio files and same plugins.

What a helpful forum lol

Did you backup/archive the project as I suggested? Whats the sample/bit date rate? Are you realtime stretching/pitch shifting?

Hard Disk speed and access should be no different between DAWs. It seems odd that disk overloads are occuring.

What a helpful forum lol

Dude, ignore unhelpful comments and be thankful for those reaching out!

If I recall and I do, it was recommended to use a secondary drive for all Cubase projects since way back when. Im guessing this is an old code area in Cubase

This points to the fact that you are more than likely correct, Cubase is not optimized well to run off an internal HD. I bet an SSD would fair better?

I have and use all three DAWS you are quoting there. I haven’t had any reason to test them though as I never use the internal drive here for any Projects

Carry on

It would be interesting for you to do the test using the Mac sound card and not the Steinberg interface just to see what ya get there.

I don’t know, I find this interesting. I’ve recently built a new PC DAW and even though I’ve upped my memory, my cores, moved from Win7 to Win10, and now run all SSDs, (internally), I do have a better Cubase experience and more ‘ease of use’ with the added power - but - eh, the Average Processing Load bar still reacts more than I had hoped for. Sure, with my 4 core Win7 DAW the Processing Load bar did go higher than with my new 6 core processor but plugins like Ozone 8 Advanced still suck some juice. I think this test is accurate.

You have 37 tracks in your cubase session, but only 2 audio files, is that right? While I don’t know what your problem is or why only Cubase is showing the i/o overload, I can tell you it is unusual for Cubase to have a disk i/o overload on a session like that and I think that’s probably why you haven’t received many responses to help you solve your problem. It would not be unusual however, for an 8 year old hard drive to have problems.

Yes, and everyone knows that hard drives will first start to perform particularly bad with Cubase before the effects show up elsewhere - most hard drive diagnostics run a version of Cubase for this very purpose… right? :slight_smile:

Nope. Not on my system… :wink:

maybe you do not understand the CPU meters correctly, and you can use Asio Guard for better performance.

please read this article:

Another nice Video “Asio vs. Performance Metering”:

Here on my OSX:
Cubase vs. Logic very close results (when you use the same third-party Plugins!)
But If I use Asio Guard, Cubase 10 runs a bit better than Logic 10.


But it is not a CPU issue . Its a disk reading issue! the orgianal post clearly shows a problem with disk overload.

You’re asking if there could be a problem with one particular file on a hard drive? Yes. Could this only affect Cubase? Yes, if the other tests were done with copies of that file instead of the same file. I take your point that this seems unlikely, but without more details about the OP’s problem and how the tests were performed, that’s probably as close to an explanation for what he’s observing as he’s going to get.

You made a comment that it IS unusual for Cubase to be at fault, but NOT unusual for a hard drive to be a fault, i’m pointing out that it’s most likely to NOT be a hard drive failure so they don’t go spending out on a hard disk based on some janky advice.

On my system cubase performs worse (heavier on cpu) than Reaper or StudioOne. Tested both on Mac Book and on desktop (specs in the signature)

Here’s the facts:

3 different DAWS

exact same project.

2 audio tracks duplicated as many times possible with one instance of Scheps Omni channel on each track

1 Groove Agent vst track

Optimum settings selected to produce maximum performance on each DAW

ALL DAWs using the same internal 7200rpm drive.

Results quite different.

Cubase 10.0.30 ( just updated ) experiences HD overloads while the other 2 DAWs do not and can run quite a few more audio tracks than Cubase.

Here are videos:

Logic Pro 10.4.5

Studio One 4.5

Cubase 10.0.30

Sure anyone can simply suggest I buy a newer computer or swap out the 7200rpm hd for an SSD but that’s not the question in this test.

Do you have automatic hitpoint detection enabled ?
Tried using the backup function in C10 to make a fresh copy in another location?
Tried copying the project to an external drive?
Tried different preload settings in Cubase?
Defragmenting the drive?
How is the memory situation when running the various DAWs?
No backup/update or other task running in the background while testing? has happened to me :slight_smile:

Can you post the project? I don’t dispute the idea that you’re getting poorer performance in Cubase, but I do suspect something else is going on. For instance, when you import audio into Cubase, it puts the audio tracks in “Musical” mode by default, so basically enables time-stretching. I don’t see that little quarter note icon on the audio clips in your screen capture, but you may want to double check that (looks like your audio clips may have been trimmed - not sure if that hides the icon).

So if it were something like that, and someone wasn’t paying attention, or just doesn’t know about that, they may think, “hey, Cubase uses a ton more CPU playing back 20 audio tracks than Reaper!” Then after turning off musical mode they realize, “oh wait, Cubase uses about as much CPU doing the same thing as my other two DAWs.” This exact thing happened on KVR a few days ago. Someone did a compare, Cubase was eating a ton of CPU with 20 audio stems, and the other DAWs weren’t. They had musical mode enabled. Turned it off, Cubase was right there with the other DAWs. I only suggested it to that poster because I recently imported stems and had to turn Musical/time stretching mode off.

Now, I’m not saying that’s definitely what you’re seeing, but what I’m suggesting is, if you post the project, other people can try to replicate your settings and double check your work. Kind of like peer-reviewed studies. Sometimes having another set of eyes doing the same thing can lead to different results or find an issue.

I have multiple DAWs on my computer, Pro Tools, Cubase, Logic, Studio One. I don’t notice any less performance in Cubase. I actually notice a little less performance in Pro Tools on some sessions with lots of virtual instruments. In saying that, it’s a pretty fast computer.

I noticed in your videos that the cpu bar was maxed out in Logic, higher in Studio One than in Cubase. It might be a muti-threading issue. Do you have hypertheading enabled? I remember that was an issue on really old CPUs with Cubase but I’m not sure if it’s still a problem in the newer versions of Cubase. Also, the UR824 interface you have has extra functionality in Cubase. That is a variable. You can delete a file to break the functionality in Cubase for the UR824. I forget which file it is but you might be able to search online to find it.