Periodic pop/noise on playback with certain buffer settings

Hi guys,
i have a strange problem. Whenever i use a different combination of Sample Rate and Buffer Size than 44100 and 512, i get this strange periodic noise on playback with Dorico. With every Playback template i use (tried Halion and VSL). Only Dorico is affected, Cubase and other audio (browser, local mp3’s) work normal.
Since i want to increase the buffer to 1024 for performance reasons, i don’t know how to do this. I’m not an expert in these subjects (sample rate, buffer…), so maybe there is some stupid/obvious setting i made or didn’t made but i can only think of the “Device Setup → Device Control Panel…” in Dorico.
I made the video with the settings 44100 and 1024. Has anyone an idea how to get rid of this?

do you by any chance have Finale open as well ?. I’ve noticed that Finale is a total hog on the audio system and get crackling noise whenever it has to share resources.

Hi @frave ,
I’ve never heard or experienced something like this.
What VSTinstrument are you actually using for playback? Does this also happen with HALion Sonic SE and the default playback?
Normally increasing the buffer size should stabilize the audio, not worsen it. What if you create a new organ project with the HALion Sonic default template? I would be very puzzled if that also did show that behaviour.

@tom_ginsberg no, i don’t use finale. it happens even Dorico is the only application running.
@Ulf The VST in the previous video was VSL, but it happens also with HALion Sonic SE. I created a new project as you suggested and created a new video. As you can see, the pop vanishes when i set the Buffer to 512.

1 Like

found out a little bit more:

  • sample rate set to 44100 or 48000, it works with every buffer size < 1024.
  • sample rate set to 88200 or higher, it works also with buffer size 1024.

but unfortunately, by raising the sample rate i lose the performance advantage.

… and double checked it to be sure: Cubase works fine with e.g. 44100/1024

That’s all really strange. What Cubase version do you use? Also, what audio interface or audio driver?

Cubase 11 (
Focusrite Clarett 2Pre USB
Focusrite USB ASIO (Driver version

Even more strange, because Dorico 4 has basically the same audio engine as Cubase 11, so I don’t see any reason why Dorico’s audio engine would behave differently here.
But maybe it is ASIO-Guard that is making trouble here. I don’t have an apropriate computer at hand, but somewhere in Dorico’s Preferences Dialog is somewhere a section with Advanced settings. If you click there and switch off ASIO-Guard, does that make a difference?

1 Like

Yay!! That did the trick! After switching off ASIO-Guard and restarting Dorico, the crackling vanished! Thanks a lot, Ulf! Searched multiple times in the preferences but overlooked everytime this darn thing…

@Ulf Just a last question: what are the noticeable drawbacks by switching off the ASIO-Guard? Tried some “heavier” scores and it seems performance is not or only slightly affected.
Thanks and have a nice weekend

Hi @frave ,
there are no drawbacks. If it does work for you, then that is fine.
On the other hand, it should also work with ASIO Guard switched on with you, but that is a bug in the audio engine. Cubase 12 has already a fix for it and Dorico’s audio engine will inherit the fix in the next major update.
ASIO Guard is actually a technology developed for stabilizing the audio performance with smaller buffer sizes. It really turns the world around if now suddenly with bigger buffer sizes problems start to arise with you. But as I said, that is actually a bug.
In general, using bigger buffer sizes puts less stress on your system. 1024 sample is already a quite big size and so even without ASIO Guard it should not pose a problem for your system to produce smooth audio output.

1 Like