Petaluma Arpeggio Line Broken

Looking through searches and screenshots online, it seems that the arpeggio line I have here (see attached) is bugging out a bit, being drawn as a broken/dashed wavy line. Can someone tell me how I might fix this? Or if it is in fact designed that way? I don’t see any engraving options to make it a single/connected wavy line.
Petaluma Broken Arpeggio Line.png

It is not designed this way, there should be only one line with the arrow at the bottom. I cannot try it on my system, there might be a problem with Petaluma here

It looks like a font problem, certainly. Does this look incorrect in all projects, or just in this one? Does it look incorrect in projects that use Bravura instead of Petaluma?

Thanks for the confirmation. Just tested a bit. That line looks fine when in Bravura. And the problem seems to be specific to this project file, as it’s not happening on a new project using Petaluma. Even copying the broken line and pasting in a new project creates a continuous line. Just updated my signature with my version of Dorico as well, if that matters.

I’ve done a Save As and am attaching a file stripped down to just that measure (apologies I didn’t do that in the first place).

Any ideas on how to fix this without copying and pasting everything into a new file? (I don’t want to lose any of the engraving, notation, or layout options I’ve been adjusting in this project.)

I think this bug has something to do with switching between music fonts with the musical content already on the page. If I copy and paste into a new project file that is set to Bravura, then switch the new project to Petaluma, the line becomes broken. If I undo, switch to Petaluma first, then paste, the line looks correct. I can’t, however, seem to get my original file to generate a proper downward arpeggio line no matter what order I copy, paste, and switch music fonts.

I’ll also note this problem only applies to downward arpeggio lines, not upward (where there is no arrow).
Broken arpeggio (393 KB)

If you go to Engrave > Repeatable Symbols and find ‘Arpeggiato down’, set the ‘Repeat offset’ value to 1.02 and you should find that takes care of the problem.

Hmm, I can’t find “Repeatable Symbols” anywhere in the Engrave menu or in Engraving Options. I did find Music Symbols and the “Arpeggio wiggle segment, downwards” item in that, but there is no “Repeat offset” value to set. Am I missing something, or is that perhaps something in Dorico 3.5? (I have 3.1)

Ah, that is indeed a new feature in Dorico 3.5, my apologies. I’m not sure how you managed to get the relevant value to be wrong, then, given that you’re running Dorico 3.1.

The other way you can fix it, which is a bit more destructive, is to do Engrave > Music Fonts and switch back to Bravura, then go to Engraving Options and click Reset To Factory, then go back to Engrave > Music Fonts and re-select Petaluma.

Alas, I’ve tried your suggestion, and downward arpeggio lines still remain broken.

If you want to send me the original project, I’ll fix it for you as described. You can email it to me at d dot spreadbury at steinberg dot de.

I’ve never heard of a developer being so kind as to personally fix a document for a user. Thank you Daniel! Just emailed.