Phantom Midi notes play without data being there when midi tracks are selected

Hi guys,
I have Cubase 12 pro with six or so external midi modules and some VST modules…
For well over a year I had noticed when playing back this tune that I’m working on if I have ANY midi track (not audio) selected (either by using the Behringer X-Touch or by simply selecting the track by clicking on the track header or within the mixer console, the track select will play what seems like “random” notes not related to the tune.

The what seems like “random” notes is coming from the selected midi track but there isn’t any data in the track. When the play head gets to the place in the track where there is data it will play that along with the “random” notes. This will occur for outboard midi track or a track with midi from a VST instrument.

I say “random” because they are not part of the song nor are they parts that I recorded. They must be coming from somewhere.

I soloed out the Sax. while having the sax track selected. When the sax mini parts are played I can hear a bunch of notes that don’t being there. I did the same with the midi piano track. I don’t think the notes are random now but they aren’t correct and I can’t see anything in other tracks that may have caused this.

When I try and render the midi track…say like a VST sax…the random notes are playing with the midi data that’s present in the track. Actually when I listen to the “random” notes they seem like in some cases…with the Cello that it plays the notes that are present but there is like an cord of notes playing an octave higher…despite the fact that there is no data in the track at all…or in any other track in the place where the play head is.

The one thing I do remember changing a while back in the MIDI menu was the “Midi thru active” but I just toggled that off then on again while things were playing but the problem still exists.

Because I have to select the midi track I want to render, after I render it to audio these somewhat random audio is not part of the audio track that was just rendered.
I’m at a loss here. This is the first time I was forced to resolve the issue because this is the first time I needed to render midi to audio to send the project out for mixing and mastering.

Anybody have any thoughts on what’s going on here?
Thanks guys
Chris

Hi,

Make sure, you are not using one MIDI Port for the MIDI data and Cubase remote controlling, please.

Also, make sure, there is no MIDI Loopback involved (do you use any virtual MIDI Ports by any chance?).

Thanks Martin.
I’m not clear on what I have to do to confirm this. Could you give me a little more information on what I should be checking?
Sorry for the ignorance on this one.
Chris

Hi,

I expect you are using X-Touch as a Mackie Control Device. Right? Make sure, the X-Touch MIDI Port is not enabled for the ‘All MIDI Inputs’ in the Studio > Studio Setup > MIDI Ports Setup, please.

Could you attach the screenshot of the MIDI Ports Setup window, please?


Port 4 and 2 are set for All Mini inputs.

I seem to recall this was done because I use a breath controller and had four midi CC controllers.

I sort of remember that one of these if not both had to be set this way to allow either the breath controller and/or CC controller to work…but I could be mistaken.

Ok so if I disable this, you think this is the issue?
Thank you Martin
Chris

Hi,

This looks OK to me.

Ok well that’s good.
I recall needing to have this setup this way do to the use of a breath controller being use with a General Music S2 keyboard for the wind instruments.
It must be related to midi somehow right?
I won’t be able to render midi to audio without figuring this out.
It didn’t always do this…but it has been like this for at least a year. I’m not well versed in the setting within Cubase (obviously). I feel a bit overwhelmed when stuff like this happens.

It’s such a weird thing.
I’ll mess with this a bit more. Whatever it is has to be relate to a midi setting. I have to go shopping for food but I’ll be back and see if I can find something to fix this.

Thanks again
c

Hi,

Yes, I believe it has something to do with the MIDI settings.

Ok thanks. I’ll poke around and repost if I fix the issue. I can’t be the only one experiencing this issue.
C

You could also check the midi tracks for any midi insert effects being used. Some effects can generate midi data by themselves.

1 Like

I found the problem.

In the MIDI menu under Setup Editor Preferences and then under the Record section under MIDI it’s set to “Record Enable allows MIDI-Thru”
If this is disabled it works…but I’m I approaching this from the wrong side?

Is there a way to not have the selected track not automatically placed in record mode?

C

1 Like

Thanks Johnny,
I don’t have any effects on any midi tracks…well at least not in this song.
It’s been over year since I’ve had Cubase and I’m still fumbling around…cluelessly.

I’m still glad I bought it because there is almost nothing it can’t do but the learn curve has been steep.
C

Ok the better way to resolve this was to go to Edit/Preferences/Project&Mix Console and DISABLE “enabled record on selected midi track” and for consistency “Enable record on selected audio track”

Thanks guys for getting me on the right track
C

Hey guys,
Earlier today I wrote a post titled " Phantom Midi notes play without data being there when midi tracks are selected"

I finally got this working and I thank the guys that help me figure it out.
After rendering all of the VST instruments MIDI to audio I tidied things up. I created a folder track called “Original MIDI VSTs” and dragged all the VST midi tracks into this new folder.
Then I gave the tracks a listen (the audio version of them). Everything sounded great except one weird anomaly in a woodwind track. Like a little “gergle” sound. I know it wasn’t in the original VST midi so I tried to listen to the original track. It wouldn’t play. I checked all of the recently rendered VST midi tracks…none of them would play. I did some research here on the forum and found out that after rendering midi to audio it mutes the events (not the track itself!) within the track. I don’t understand why it would just show a yellow MUTE button on the track…but anyway. That’s not what this post is about.

When I unmute each event in the woodwind track it sounded way off. I saved the project and open up a recent version of the song that was slightly different in it’s mix. I opened up the woodwind VST instrument (Spitfire Audio Abby Road One) and the settings were completely different! The settings of the VST instrument went back to it’s default instead of what it was within the project. How did this happen? Did it occur because I moved the tracks to a folder? I’m screwed now because all of the “original” VST midi track instruments are not set to what I set them too…sure the data is there but none of the setting of the instrument are there! I feeling like crawling under a rock for a week or two.
The whole point of rendering the VST midi to audio is to prepare it to be sent out for mixing and mastering.
Any thoughts on this guy?
C

Hi,

Obviously, some of your MIDI device sends unwanted MIDI data to Cubase v

1 Like

Guy this is the sort of thing that makes me want to trash this Windows setup with Cubase and go with a Mac and start over. These weird problems I’ve been having from day one with Cubase on this purpose built PC. So many unanswered problems…but no clear answers. Music production is hard enough without adding PC/software issues into the mix.

The most common reason folks have Instrument sounds unexpectedly changing on them is that they have unwanted MIDI Program Change messages in a MIDI Part. Typically this happens with downloaded MIDI files that use GM Instruments. The easiest way to check is to look at your MIDI Parts using the List Editor set to hide the Note data.

1 Like

I am having the same issue here with unknown source of midi sounds on my midi track. When I enable recording on that track, the second time I hit the play command it there is a chord sound, through the track’s vst selected module. Then when I disable the recording on that track, the first time I click the play button it plays that mysteryous chord again and does not play it again if I stop and click the play button over again.

And by the way, C.F.Christopher, If you believe tat a MAC setup will give you the heaven you expect, while producing music, then I suggest you’ll be prepared for some other frustrating phenomenon. Good luck to us all :slight_smile:

I intermittently have this problem, and I first heard it last year, when i was using my old Korg Karma. That ha now been retired and I have a Nektar LX 88, and it happened again today with an empty Halion track
I usually mute the track and then carry on.
It hasn’t mucked up any recordings though.

I don’t have any other midi devices connected to Cubase (pro 13)