Piano MIDI File Importing Issues (Dorico Pro 4.10)

I’m using Dorico 4.10 on Windows 10 64 bit.

When trying to import a MIDI file from some time ago (not a Dorico score) of a piano part of two staves with treble and bass, Dorico is showing the entire part on just one stave and, therefore, not splitting the file into the treble and bass parts.

I have tried changing just about every option in the import dialogues without success. To check and test my original MIDI file I tried opening this with Notation Musician and this opened as well as can be expected with both staves and appropriate splitting of treble and bass parts. I should add that this was just double-clicking on the MIDI file straight out of the box with no further settings or dialogue screens.

I’m sure I’ve missed some setting in Dorico and would appreciate any help with this.


Dorico 4.10 MIDI Import Sample:

Notation Musician MIDI Import Sample:

When you open the MIDI file in Dorico, take a moment to check in the MIDI Import Options dialog that the tracks have been correctly identified as the expected instrument. Once Dorico knows that the track in your MIDI file is meant to be a piano, it will import sensibly onto the expected grand staff instrument.

Thanks Daniel I have it.

With a little trial & error I have a near perfect MIDI import.