Piano with three staffs

@arco
You don’t need flows to change the number of visible staves. Hide empty staves in Layout Options will do it. Just remember to click the setting for hiding individual staves within an instrument.

…and besides, even violins sometimes use multiple staves (I’ve even seen 3). But supposedly, when it’s implemented, it’ll be possible even in extreme cases.

@fratveno, I’ve just started a piano sonata in Dorico and I need a 5 staff template. I no matter how hard I tried, I couldn’t make my template as neat as yours from either a finale or Musescore Xml. How did you make the template in Musescore? Can you please make 5 staff template?
When I tried to make it it gave the attached result.

This looks like it should work just fine - click on the first rest and type shift-C to change the clefs at the beginning (g for treble clef, f for bass clef).

@dormusic, I hope this can be of some help: it’s possible to create some extra space between the instrument name and the brace just by adding a space after ‘Piano’ in the instrument name.

Regards,

Stefaan

Any idea why do I get ‘invalid file format’ error? I have changed the suffix to ‘mxl’.
Thank you

It’s a zip file. Did you unzip it?

Is there now a way to make a three-staff piano document without the workaround of having to create it in another program and then import it via xml?

You should be able to add a third staff easily now, right? Select the first note, then do Edit > Staff > Add staff below / above.

Ah, thank you. Those options were greyed-out in both Setup Mode and in Engrave Mode and I didn’t think to have to select the first note or rest in Write Mode before they would become available.

I’m still not able to achieve a cross staff for right hand piano. I’m starting with notation on two saves.


Then I create an additional staff and only select the top notes.

When pressing N to move them to the upper staff, they appear, but not in the ‘notated’ octave as needed.

This is what I would like to achieve, where the upper staff is 15ma.

Any attempt to change the clef on the added staff did not give me the right notation.
Any hint?

For now I transposed the moved notes 2 octaves down, but that’s really just a workaround to show what I’m after.

You need to invoke the caret at the start of bar 8 (by double-clicking on the staff, or selecting something on the staff and hitting Enter).
Then you need to ensure that the caret has shown on the correct staff. Where cross-staff notation is concerned, it may be that the caret appears on a different staff. Use the up arrow to get it to the top staff.
Then type Shift-C g15ma Enter (or any of the various alternatives listed at https://steinberg.help/dorico/v3/extra/dorico-3.5.10-popovers.pdf)

If you want to show a 15ma line as opposed to a clef, it’s a similar process. Put the caret on the correct stave, then type Shift-C 15 Enter. Then hit Space a couple of times in order to give it duration. Note that the 15ma line will not appear at all until you’ve hit Space.
You can then extend it further with Space, or leave note entry (Escape) and use Shift-Alt-Left/Right to contract and expand, or grab the handle with the mouse and drag it.

Hi pianelo, thanks for your quick reply. I have learned many things from your forum responses so far.

I followed your steps and now have a clef, but the pitches still remain visually 2 octaves too high.

Is there another engraving setting I have to invoke to automatically adjust the notation to respect the treble15 clef?

sorry for misspelling your name :wink:

No problem - I’m not going to attempt to spell your name :wink:

You can either set the clef’s Octave Shift property, like so:

or set this Notation Option:

You could also use the notation option for whether clefs with octave indicators respect those indicators or not (essentially acting as a long-running octave line).

(Leo, you type so incredibly fast…!)

Thanks to both of you. I’m all set for now.
Hans

I just do the screenshots. The cat does the typing :stuck_out_tongue_winking_eye:

3 Likes