Pickup bar rests

Please help me learn what I am doing wrong here. I can’t seem to figure out how to put a rest in the LH part of the pickup bar on this piece. I can enter notes, but I can’t change them to a rest. I followed all the suggestions in the manual that I could find.

Screen Shot 2021-09-28 at 3.37.12 PM


When you delete a note, Dorico displays a rest automatically. You don’t need to enter rests as one does in other programs. (Was that your question?)

Well, I didn’t think so BUT that did the trick. I was trying to input a rest by invoking the caret - hitting comma then a quarter note (which should input a rest) but it didn’t work. What I did was put in a quarter note to see if I could put anything in there. Then I took the screen shot.

But once I deleted that quarter note per your suggestion, it worked. Seems weird that you have to enter a note and delete it to get a rest, rather than just being able to enter a rest there.


Rests in Dorico are just the absence of anything else - they’re not typically something that need inputting at all.

If there was previously nothing in that gap, on the bottom stave before the first barline, the usual explanation is that MusicXML has been imported and the following note (as a byproduct) has its “Starts Voice” property turned on. Selecting that first note and unsetting that property will fix it.

If you really do want to input a rest - and again, it’s much quicker to just move the caret along the rhythmic grid and enter notes where required - you need to turn on rest input with comma, set the note value, then type any note (A-G) or Y (the generic key for inputting rhythms). This will have the desired effect of overwriting a note with a rest.
On the other hand, if there’s already a rest at that location, this is a fruitless exercise unless you also hit O to turn on Force Duration (before inputting the rest), as without Force Duration Dorico just thinks “ah well there’s already a legal (e.g. whole bar) rest at this location, and the user’s trying to add another rest. I’d better join those back together as per the global Notation Options”.


thanks Leo.

This wasn’t a MusicXML import, but it perhaps it was marked as a starting voice. i knew you don’t really have to worry about rests, i just couldn’t figure out why that bar was empty in the left hand. guessing you’re right about the starting voice option.