*PICS now! Please confirm these simple midi & audio bugs!

*EDIT#2 - pics below in a later post!

EDIT - important note, I tested this further and it definitely seems to be a bug. It does not do this problem with the first two or so midi recordings. Then after that it creates parts that reach all the way back to the last recorded part. So if you test this it’s important to do it several times for the bug to show. Record one bar, skip a few bars, record again, etc. Do this about 3-4 times and you will see the newer parts being created in this extended way.

If I record a midi part on a track that already contains a midi part, the newly created part extends past the locators to meet with the previous midi part. In other words it’s like this. I record a midi part from locator position 2 through 10. Then I set the start locator position to 12 and the end locator to 14 and start recording from the first locator using the record button (actually this happens no matter where I start recording between the locators). When recording is done I hit stop and instead of simply getting a midi part that is from position 12 through 14 I have a midi part that is from 10 through 14. All data is correctly placed of course between 12 through 14, there’s just emptiness in the extended part.

I have confirmed this behavior does not exist in Cubase SX3, which is what I came from. It also does not do this in Cubase 6 if I first double click to create a midi part then record. It’s a very minor bug with a simple workaround, of course, but it would be nice to not have to create a part first every time before I record. So can anyone confirm this? Or, if it turns out to be some type of preference setting, like auto-glue parts or something, please point me where to change it.


Rev.

Aloha Rev,

Being a real 'MIDIot (and one of the few that wished
Steiny still made an all MIDI programme) your post has intrigued me.

I tried your example with a new song using the ‘default’
Project Assistant and all seems fine here.

I get two separate MIDI parts.

One part from bar 2 to 10 and the next part from bar 12 to 14.

I tried this six (6) time with the same results.

I am off to work now so I will try this again tomorrow.

If I get a different outcome, I will then post those results.

HTH
{’-’}

I think the behavior depends on the cycle mode that you have set, i.e. mix, replace, overwrite, stack, etc. That may explain why you are getting different results and the change in behavior. I have had some unexpected behavior with the parts as well but never got into the weeds because, as you have already noted, it is fairly easy to readjust the part size.
I am going to check the manual and see if it says anything about cycle recording and parts, etc.
HTH
J.L.

I have it set to Mix/Merge, which is also what I always had it set to in SX3. I’m going to have my friend in Florida with Cubase 5 test this today. But on my machine it always starts stretching the newly created part to meet the last part after doing 2-3 recordings. It shouldn’t have anything to do with the cycle mode setting or it would do it consistently rather than only after the first two or so takes.

On another note… I’m using 6.01 just because I’d read some complaints about ASIO spikes and wanted to err on the side of caution as the latest updates fixes don’t seem to really apply much to my usage. I may upgrade it tonight to 6.02 and see if it still happens.


Rev.

Could it be you have retrospective record enabled and the first note of the take is slightly early? How about the first note just being slightly early? Is Snap MIDI Part To Bars enabled? Just spit-balling.

Nope, does it with or without it enabled, already tested that. I just spoke with my friend in Florida with Cubase 5 and even using the same default project template emailed to him his does not do this problem. So it definitely seems to be something with Cubase 6. Maybe they fixed it in the 6.02 update and didn’t list it, I can only hope and will try the update tonight. It’s a weird problem because I can load my old templates from SX3 and it does it. Or I can create a brand new Cubase 6 project or use the included templates and it still does it. And it’s always after two or so recordings that it does it.


Rev.

OK, I made some pics. My friend in Florida was kind enough to send me an ISO of his Cubase 5 disc and I installed it and updated it to 5.5.3 and it works perfectly!! Here are pics showing the bugs/new behavior. Someone PLEEEASE confirm this!! I will need to work in Cubase 5 until Steiny addresses this nonsense.

Below is a pic showing if I record midi bars individually in Cubase 5 via hitting the record button (ie. not double-clicking first to create a part before recording). In Cubase 5 it creates it’s own individual part. In Cubase 6 however after the first two recordings it starts extending the midi part to meet the last part:

Cubase 5

Cubase 6

Next is the audio recording. In every single version of Cubase before 6 if I begin recording in the middle of the locator section and loop a few times it only keeps the full audio takes meaning full passes from locator 1 to locator 2. And little pre-record or end-record slivers are ommited. In Cubase 6 it leaves these parts which I don’t want it to:

Cubase 5

Cubase 6

Again, someone pleeeease confirm this for me. I am using the fully updated versions of Cubase 5 and Cubase 6 in these tests.


Rev.

One last thing. I just tested copying over the Cubase 6 preferences (defaults) file into the Cubase 5 location. It did indeed set the preferences to what I have set in Cubase 6 and the problem still persists. So, this is definitely seeming to be bugs rather than any type of preferences setting.


Rev.

MIDI:

Just tried the MIDI record and the second recorded part in my case in fact overlapped the previous. I got a screenshot (attached) but I now can’t reproduce it! It seemed to go back to where the cursor had been stopped after the first take.

How did you do your recording? I’ve used Punch In/Out. [EDIT: See next post]

AUDIO:

I get that bit of preamble on my audio takes too. In my case it suits as being a bloody guitarist I’m always coming in early. I’m not sure whether you’re referring to the pre-roll or the pre-record buffer setting in Prefs* but it’s the latter that puts this little bit on the beginning. If it’s any consolation, it does drop the Snap bar in the right place.

  • i.e. Prefs - Record - Audio - Audio Pre-Record Seconds

And no, it doesn’t automatically delete silent passes at the end of a take. Does it? - he asked suddenly unsure. Did it use to? I can’t remember. Not sure I want it to, to be honest. I’d rather do my own tidying up and not leave it to the machine.

Hope this helps.

Version info: C6.0.2-64 on Win 7-64
MIDI - Recorded part overlapping previous.JPG

Okay, might have an answer for you. I just reproduced your situation exactly (i.e. back to the previous part but not overlapping). I’ll take you through what I did step-by-step so you can see where what you’re doing fits in:

  1. Set up 1 bar loop in MIDI track with previously recorded events (as you specified). Looping on but not, I think, relevant.
  2. Set Punch In/Out both ON, back off a bar, hit PLAY (not Record!).
  3. Tinkle, tinkle, Stop.

The MIDI event is the size of the loop, as you’d expect.

  1. Now set up the loop a couple of bars on and set the Punch In point ON again (it unsets itself).
  2. WITHOUT moving the cursor - which is at the end of the recorded part because that’s where it ended up - press RECORD (not Play!).

Although the cursor hasn’t reached the Punch In point yet, Cubase is still drawing the part. Even with Snap OFF, it jumps to the previous bar to begin. (One time, I forgot to re-enable Punch In and it went back to the start of the previous take (2 bars back)! But when I tried to do this again but from several bars further along, it jumped back just the 1 bar.)

Solution? Use Punch In/Out with PLAY, not Record. I think this is the ‘right’ way to do it, the way it was designed. You may be already doing that but I’m guessing not as I can’t get it to repro when I use PLAY.

Well, I hope that helped you, it was news to me too!

Cheers,
C

Punch in/punch out is really of audio recording importance, not midi. Though even still, doing it that way is more work than simply double-clicking to create a part each time before I record, which as mentioned earlier the problem does not happen when first creating the part.

Both of these things are easy to work around. It just annoys the crap outta me that I paid all this money for Cubase 6 to have to feel like I’m beta testing. I mean… this behavior did not exist in ANY prior version not even 5.5! I’m speaking with a support tech today at 4pm and will post back after if there’s any news.


Rev.

*EDIT#2 - pics below in a later post!

EDIT - important note, I tested this further and it definitely seems to be a bug. It does not do this problem with the first two or so midi recordings. Then after that it creates parts that reach all the way back to the last recorded part. So if you test this it’s important to do it several times for the bug to show. Record one bar, skip a few bars, record again, etc. Do this about 3-4 times and you will see the newer parts being created in this extended way.

If I record a midi part on a track that already contains a midi part, the newly created part extends past the locators to meet with the previous midi part. In other words it’s like this. I record a midi part from locator position 2 through 10. Then I set the start locator position to 12 and the end locator to 14 and start recording from the first locator using the record button (actually this happens no matter where I start recording between the locators). When recording is done I hit stop and instead of simply getting a midi part that is from position 12 through 14 I have a midi part that is from 10 through 14. All data is correctly placed of course between 12 through 14, there’s just emptiness in the extended part.

I have confirmed this behavior does not exist in Cubase SX3, which is what I came from. It also does not do this in Cubase 6 if I first double click to create a midi part then record. It’s a very minor bug with a simple workaround, of course, but it would be nice to not have to create a part first every time before I record. So can anyone confirm this? Or, if it turns out to be some type of preference setting, like auto-glue parts or something, please point me where to change it.


Rev.

Hi,
Did you already have a look at the “How do I report a problem with Cubase” text?
How do I report a problem with Cubase [bugbase]

The following gif shows MIDI recording with the recording mode set to “New parts” and “File–> Preferences–> Record–> MIDI --> Snap MIDI Parts to Bars” unchecked:
MIDI_Recording_Mode_New_Parts.gif
In your screenshot we can see that you have the record mode “Merge” on. This will merge the existing data into the existing event thus extend the borders to line up as you describe. Thats expected…

It’s not a good idea to mix posts about the MIDI recording behavior and the audio recording behavior in one thread.

Regarding your concerns about updateing to Cubase 6.02: Cubase 6.02 does not have ASIO issues. However the Cubase Multiband Compressor does since 6.02 put more strain on the system.

Gr,
JHP

Why do you say that? ( :smiley: ) It works for both so why would you want to restrict your usage of it? I’d forgotten how useful it was and after this little exercise I’ll be using it even more, MIDI included, and speeding up the process by using the I and O default key commands. :wink:

Cheers,
C

JHP, I can’t get to your attachment, I get permission refused, although I’m still signed in.

The gif works for me :confused:

JHP, I appreciate your response but I will have to tell you that is incorrect. Merge simply merges with the data that’s already there. In this case there is no data at that position yet. This is not the “expected” behavior. For one, I have Merge/Mix set in every version of Cubase - SX3, Cubase 5, and Cubase 6 and the only one that does this is 6. In addition, even if I change the mode it still does this. Lastly, it does this same behavior no matter if “Snap midi parts to bars” is turned on or off! And that setting doesn’t apply to this thing I’m talking about, with that setting it should create a full bar if you only record a snippet for example. And yes, I’ve restarted the program after making the changes just to be doubly sure.


Rev.

JHP, I appreciate your response but I will have to tell you that you are wrong. This is not the “expected”
behavior.

The function is a “Record Mode” and is called “Merged”.
It has the following describtion if you hover above it: Merge recording data into existing parts
In the manual it states: Existing events in parts that are overlapped by a new recording are kept. The newly recorded event are added to the existing parts.

For one, I have Merge/Mix set in every version of Cubase - SX3, Cubase 5, and Cubase 6 and the only one that does this is 6.

The fact that Cubase SX3, Cubase 5 and Cubase 6 are different programs does not give room for arguement.
The recording modes have changed from Cubase 5 to Cubase 6.

In addition, even if I change the mode it still does this.

Can you reproduce the recording behavior in my gif if you update to 6.02?
The behavior that is illustrated in the gif is what you desire right?

Lastly, it does this same behavior no matter if “Snap midi parts to bars” is turned on or off! And yes, I’ve restarted the program after making the changes just to be doubly sure.

This is what “Snap MIDI Parts to Bars” does:
Paste from Help in Prefs:
Snap MIDI Parts to Bars
When this is activated, recorded MIDI parts will automatically be lengthened to start and end at whole bar positions. If you are working in a Bars+Beats-based context, this can make editing (Moving, Duplicating, Repeating, etc.) easier.

Gr,
JHP

Hi Jan, I think the issue is the inconsistant behavior in that the OP states it doesn’t do it on the first pass or two.

JHP, you are going on about the details of features I know well about and trying to argue this behavior is normal in my instance which it is not. I know very well what snap to bars does and already told you that. Aaaand, if you’d notice my parts are already at whole bar positions! So, why on Earth would it extend the part way back to the last recorded part??? That just makes no sense.

You haven’t helped at all in this discussion and if you don’t mind I’d like to politely ask you to refrain from further trying to help me. You clearly are not understanding the issue at hand and are trying to simply excuse it all away with suggestion that preferences are the reason, which they are not as I’ve tried many different one’s and have used the same exact settings. You then try to simply wash away my complaint by saying the versions are different programs. I’ve seen you do this in your responses to others in threads I’ve come across.

I’ve already explained several times to everyone in this thread that this behavior does NOT happen on any other version of Cubase except for 6. Cubase 6 came out what… in May!?? Sure there will be some bugs. There is no excuse whatsoever why if I record a midi part from position 4-8 then record a midi part on the same track at position 30-34 that the part should grow itself all the way back to position 8. What purpose would this serve??? - that’s not actually a question for you since I’d rather you don’t respond. Take care.


Rev.

Rev, Snap To Bars would apply if you hit the first note early. Cubase would see there was data in the previous bar and extend it.

Jan has stated;

I’d give him credit for knowing what he’s talking about.

This is the main point you should be arguing;