Pitch bend automation issue

Hi guys,

For an example, please check the attached screenshot.

When I am trying to create a riser effect and use the pitch bend option for this I never get a straight line. It’s always blocky and I can hear it in the result. It is never a nice smooth riser sound but you hear it going to the next key.

Do you know what I can do best for creating a smooth riser?

Thanks in advance.

Kind regards,


Well, here’s a thing… The vertical density of the line tool is determined by the height of the pitchbend (controller) lane!! I guess that might equate to the number of pixels available?? Anyway, if you make the lane really tall then when you draw a line you get more points on the line, i.e. more therefore smaller steps in the line.

Perhaps this will help? The problem is that we humans notice awfully small steps in pitch and if they’re not sufficiently close enough then we can hear them individually as you’ve found out.

Maybe you could make this effect using Glide or Portamento instead? Or by programming a pitch envelope on the VSTi or keyboard that you’re using. I tend to use these techniques for pitch rises myself because they’re guaranteed smooth. Then I render to audio and line them up correctly.

Also there’s probably a very old feature request for automation of pitch-bend you could look out… And more recent requests for the controller lanes to be more like the automation lanes in that you just add points and the lines are interpolated between, something like Logic has.


Turn off “snap” - or increase its resolution; or, use (if possible) VST automation instead of controller lanes.

Snap has no effect with the line tool in the MIDI editor! Nor does the Grid Type or snap resolution. And there’s no automation lane for pitch bend, even though regularly requested :frowning:

The only way I know of is to increase the height of the controller lane in the midi editor and then you get more points in the line.


Pretty sure snap resolution does affect placement and density of nodes - notice how his grid is set to 16th’s, and the pitch nodes land every 16th division…not in front of my pc atm, however, so I might be out to lunch on this

However, for pitch bend automation, I usually use the parameter within the vst itself and automate via an automation track, not via a midi controller lane. I find it’s way easier to manipulate this way.

Thanks for your replys. Unfortunately Nexus 2 doesn’t have a pitchbend functionality like Sylenth1 has.

It would be nice if Cubase let you use pitchbend in your automation. It’s an option other DAW’s have but Cubase haven’t.

I will try your resolutions.

To directly automate the parameters of a VSTi synth, what I normally do is click the VSTi into automation Write mode, then wiggle the parameter that I need to change, then ‘show all automation’ to see the new values. If there’s a pitch knob then that’s the one, otherwise its just pitch bend via midi then…


This is 100% correct, and the method of increasing the pitchbend lane height does indeed do the trick :wink:.
Don’t forget that, unlike other “regular” MIDI CC#s, which have only 128 discrete values, pitchbend has a much higher resolution (+/- 8192).

Check these out - 1st pic, snap enabled, res at 1/16, 2nd, snap disabled.
pb snap.png
PB no snap.png
Edit - just realized you guys are talking specifically about the line tool…I usually use the “draw” tool - sorry about the confusion :blush:

No problem… that 's the sort of thing that happens when you make a snap decision :stuck_out_tongue: