Pitch Change on Instrument Tracks

Hi. I have posted about this before, but it is happening again, so I’m wondering if anyone has any ideas. My audio interface is Komplete Audio 6 with up to date drivers and firmware. Often when I start a new instrument track in Cubase and play into it through my Midi controller, the pitch of the notes will change without warning, going sharp or flat as I play. This makes it impossible to record anything. I did contact NI about this previously, and they denied it could be their interface, but I have heard of other people with this issue with Komplete Audio 6. Steinberg have said before that it could not be a problem with Cubase, but it is happening, so there is a problem somewhere. Resetting the Komplete Audio unit has no effect. Any thoughts?

Windows 7 64
Decent spec laptop
Cubase 6.5

Are you sure it’s not some pitchbend or transpose midi messages you’re accidently sending?
Check the generic remote if you’ve not assigned something to pitchbend by accident.

You could try filtering the unwanted MIDi data out in Preferences (unset the Record and Thru tick boxes in the relevant section). Also have a look in the note editor, filter out the actual notes and see what data remains. It could show something like pitchbend or aftertouch data affecting the MIDI.

One more question, even though it’s not what you played, does the playback repeat the error in the same way every time or is it random?


Thanks for your responses. I think I may have accidentally figured it out. I think it was the sample rate of the project I was working in, it somehow clashed with Alchemy but when I converted the project from 44.1 to 48 bit it seemed to stabilise the pitch of the midi. Does that make sense? As you can tell, my basic understanding even of concepts like sample rate is pretty lacking. Anyway, hopefully it’s all sorted now and I won’t need to buy a new whatever.

Pleased to hear that you resolved it


I was going to say something about samplerate but figured that’d be really strange if it happened while you were playing, but I guess it’s really just really strange :wink:
Glad you got it sorted!

Looks like it was the pitch bend after all. Seems my M-Audio 49 was sending faulty pitchbend data through (a common issue?), so I’ve filtered it out in preferences as was suggested. Hopefully that’s the end of my pitch problems, they’ve been driving me nuts.




A few years late but I’ve just had this issue with my M-AUDIO CODE 49. After a lot of searching I found this link:


The section which caught my eye was this bit:

My faders are affecting the pitch wheels in Ableton. Is this normal?

Although for Ableton this was the exact problem I had. So, changing the ‘Input Routing’ on all my MIDI channels from “All MIDI Inputs” to “CODE 49” in my case solved the problem !!!

FYI my studio setup for Cubase MIDI is set at “MIDIIN3”