Pitch Shift Envelope Just Doesn't Work At All

Posted about this earlier, but worth a new thread as no one replied before, and now I have a video.

This is preventing me from doing my job as a sound designer. Can anyone confirm they are having the same problem, and how can I get in touch with someone at Steinberg to know when this is going to get fixed?


Sadly no audio in this vid, can’t capture from Nuendo, but you can see the small piece of audio selected doesn’t change in length. No pitch change occurs.


Sorry, there is no sound in the video. What’s wrong?

Hasn’t worked reliably for me either. I found that if you bounce the part you want to pitch shift to a new part. then it works as it should. It’s been like this since version 10. Very annoying.

Not sure I could be more clear - pitch bend process (without time correction) does nothing at all.

Example in that video is a brand new part.


I cannot reproduce it here. It works to me. With and without Time Correction. If the Audio event is in the Musical Mode or is not.

I can!t come to the settings, where it wouldn’t work.

Could you elaborate on your second sentence?

Everyone I’ve spoken to in person who uses Nuendo says the feature hasn’t worked since 10.


Thank you for the hint… Yes, you are right, I can confirm, this doesn’t work in Nuendo 10. I was testing in Cubase 10.5, where it does work.

So Martin, are you going to report this bug to the developers so that we can get an early fix?


There is fix in Cubase 10.5 already. So there is a fix in general already. Now it’s up to Steinberg developers/planners, how they will decide to merge it to Nuendo (and maybe even back to Cubase 10.0.60, if there will be any).

This appears to be fixed in 10.3. Phew!