Play 2nd repeat an 8va higher

Is it possible in Dorico 5 to play a 2nd repeat an octave higher? Or do I have to add the 8va part separately?
2023-09-23 2nd time 8va la fine

Unless one finds a way to send some sort of control code to the VST the second time only, I doubt this is possible.

Dorico 5 does offer play-on-pass control in engrave mode. See Muting notes/items individually. Unfortunately I don’t yet have Dorico 5 so I can’t test whether this can be applied to an octave line.

I guess the OP is right in the second assumption : writing down the second pass (one octave higher) in another staff or player and remove the staff or hide it should work. I’d bet the additional player will absolutely work, not sure it’s possible to have two staves for the same player with different playing repeats indications.

You can’t do it with an octave line, but you could do it with a playing technique that switches to a switch in your expression map that transposes the music up an octave; that playing technique could be suppressed on the first time through so that the transposition only takes effect on the second pass.

2 Likes

How can I do this for piano, which has only the natural expression?

You would have to create an additional expression in the Expression Map; and a Playing Technique and Playback technique to trigger it.

Alternatively, you could create a second, hidden piano staff, and have one suppressed on the first time, and the other suppressed on the second.

The expression map “transpose one octave up” exists in Dorico 5. For piano I cannot use the key switch note action as this may be possible for violin VST instruments. And CC or PC action I do not know how to combine this with the playing technique as in this case for piano.
Yes, I could create a hidden piano staff with Standard sound and played 12 semitones higher as normal Standard tune.

It is not too complicated. This general approach works for creating any custom playing technique.

  1. create a new playback technique (library>playback techniques) - call it something like 8ve-nat.

  2. create a new playing technique (library>playing techniques) - call it something like 8ve-up and link it to your new playback technique…

  3. Edit your expression map (Library>Expression maps). You can either just add a switch to the Default map, or work on a copy. Create a new base switch and choose the technique 8ve-nat. Set the transposition on the switch to 12.

  4. Now you can add the playing technique 8ve-up in your score. Set it to play on repeat, and hide it.

1 Like

With step 3 & 4 I could now link the playback and playing technique. Strange that it works when I click the notes or move with the arrow to the following notes, then they sound one octave higher. However, when I press playback (P) then the normal sound is played back instead of an octave up. And I have not yet set Suppress playback and on passes 1. I tried various actions: deleted the playing technique, created it once again. Copied the default instead of using the default one. Added again step 3 & 4. Included as well the bass notes with the 8ve-up playing technique. Closed Dorico and opened it up again after a while. Changed my local language to English. But nothing worked. The same situation the playing technique 8ve-up could only be heard when clicking the notes or moving the arrow from note to note. However the playback sound is normal without an octave higher.

I’m like 99% P always plays as if it’s the first repeat.

Here is a demo project based on the approach which @Janus suggested:
Play 2nd pass an octave higher.dorico (525.9 KB)

(Thanks. I’m not yet on D5, so just have to surmise about the playback on repeat)

1 Like

Thank you for your demo file. I had the same settings, but the playback has always been the regular sound. In your file i have added also a DS al fine section, and here it worked. Now I created my entry from the scratch again, but here it does not work. Although when I click the note in the Segno section it sounds an octave higer or move with the arrows to the next notes in the section. However the playback of the whole piece ignores this playing technique. Isn’t it strange. Here the demo with my addon you sent and the new piece I created from the scratch. Could it be that there is something different in my playback settings. However your sheet worked.
Play 2nd pass an octave higher 02.dorico (972.4 KB)
Black Forest Polka 03.dorico (747.4 KB)

Here is a revised version of your project:
Black Forest Polka 03 Revised.dorico (1.1 MB)

The problem was caused by the articulations you were using, so I had to create add-on switches for the Accent and Staccato playback techniques in the Default expression map. I also changed the properties for the 8ve-up playing technique so its playback would be suppressed on the first pass.

1 Like

wow, great, that’s the solution of my problem, thanks a lot for your support, now I have learnt a lot. Just one more question. Is it possible with this playing technique to have only the melody playing 8va, whereas the bass is staying on the original bass line?

Yes, just switch to Play mode and click on the button labeled Enable Independent Voice Playback in the left panel.

yes, of course, thanks a lot.