Play function during Zoom, overloads

Hello all,
This might not be a Dorico specific problem… but need help figuring out how to optimize playback. In cubase, I render the instruments that I’m done messing with, so it has never been a problem. On Dorico however, my 2013 machine is having difficulty playing the vst on a string ensemble piece without distorting the playback every bar. Here’s what I’ve upgraded on my laptop since 2013… I’ve taken out the CD drive to put a 2nd SSD in. I switched the old harddrive to SSD. I put in a new 16 gig RAM chip. Original specs: intel core duo i5.

Is there a way I can change something to make playback more amenable? I’m using BBCSO, and I guess I could take out the playing techniques of the strings to make loading easier, but I’d like to have the options of the piece playing back accurately the techniques. Also, I hate having to adjust the key switches every time I start a new piece, since it remembers what I’ve switched off.

Any one gone through the same problem as me and has a solution?

Have you tried increasing the buffer size in Edit > Device Setup?