Play what I write - not what I record

I’m not a keyboardist. So what I record is at best, best guess. So I record, go into Write and fix it, then play it back to see how it should sound. The problem is, it’s still playing back what I recorded, not what I fixed. I can see this when I open Play and look at the piano roll. What I fixed is in the thick colored lines. What I recorded underlines the colored line. How the heck do you turn off the recorded play back in favor of the written notes.

https://steinberg.help/dorico/v3/en/dorico/topics/play_mode/play_mode_notes_playback_overrides_removing_t.html

Thank you sir. I’ll give it a go.