Playback 1/2 step low?

I’m not exactly sure when this started, but Dorico is currently playing everything back 1/2 step lower than written. Playback Options/Tuning has A set to 440 and my Default Expression Map has transposition set to 0 so that shouldn’t be doing anything. It doesn’t appear to be file specific as all files seem to currently exhibit this behavior. I’ve checked my MIDI keyboard with my piano and tuner to make sure it isn’t somehow playing it transposed (even though that setting is visibly off) and my keyboard is correct. Dorico definitely wasn’t doing this last week so it must be something I’ve inadvertently changed. This is maddening as I’m trying to write and spot-check voicings though. If I export XML, and import into Finale it plays correctly at pitch.

Here’s a sample file exhibiting this behavior. I’m curious if it plays back at pitch on another system or if it’s 1/2 step low. Anyone have any idea what’s going on? I’m trying to finish an arrangement for rehearsal tomorrow and this is driving me nuts.
HalfStepFlat.zip (406 KB)

Go to Edit > Device Setup, change the sample rate setting to a different value, wait a moment, then return it to the original value (which I’m guessing should be 48kHz), and that should sort it out.

3 Likes

Thank you, thank you, thank you! Playing back correctly now!

1 Like

Can you please explain why that happens?
Your method is working fine, but it’s a workaround.

Having the same problem. It happens, when I start other Software that uses audio playback.

Please fix this issue with an update.

There’s a rather infamous video of this biting Van Halen on stage…

The keyboard samples for Jump were loaded in at 44.1 instead of 48khz and so they were…sharp.

https://www.youtube.com/watch?v=LCIyeXn1sKQ
Fun starts around 1:10.

Fun to watch Eddie try to work around everything being about 1.6 semitones off.

CeE123, we can’t fix this problem: if another application on your computer is changing the sample rate of your audio interface, that’s the problem you need to address. We can’t change the behaviour of other applications on your computer. Sorry!

I haven’t had this happen again since my original post, but can Dorico “see” what the system sample rate settings are? If it can, it would probably be nice to have Dorico issue some sort of sample rate mismatch warning to alert the user.

I think that’s the point. Dorico cannot read your sound card info.

The only thing Dorico can “read” is whatever sample rate the ASIO driver is using, and presumably it only gets that information at startup, or when you go to Edit / Device Setup and change it.

If another app changes the audio configuration while Dorico is running, there is no way it can tell Dorico it did that, even if it somehow “knew” that telling Dorico would be a good thing to do (which is unlikely).

In fact it may be that there is a way for Dorico to be notified of a change in sample rate, and it could then in theory respond to it, but at the moment the best approach is to ensure that all audio applications on your system are set to expect the same sample rate.