Playback at wrong speed

Hi,

I have problems with playback, everything is played back at half speed (including all pitches one octave too low).

Anyone recognises this?

Erik

My sound card was set to 88.2 kHz, and after setting it to to 44.1 kHz, playback in Dorico is now at the correct speed!

Seems like a bug to me (even though the workaround was simple enough)

How could that be a bug? That’s literally what playback at 88.2k should do. Dorico is just doing what your soundcard told it to do.

That’s literally what playback at 88.2k should do.

Er, IMO that’s a strange way of thinking of sample rate. The common sample rate of 44.1 kHz is just an arbitrary number (originating from the early days of the CD if I’m not mistaken). There is no reason to treat it as the only “natural” sample rate, and to treat every other possible sample rate relating to that?!

I would expect Dorico to behave like other programs; that is to generate playback matching the current setting of the sound card, so that playback sounds the same regardless of sample rate.

(BTW, I’m on macOS, and in most cases CoreAudio performs automatic sample rate conversion behind the scenes. I would have been less surprised if this had happened on Windows)

Hi Erik,
you are quite right. Dorico can play back correctly at any given sample rate, but here we obviously have a case where in the background the sample rate was changed and Dorico did not get informed properly and was still playing back according to the other sample rate. That leaves the question why the notification did not happen. Normally the notification from CoreAudio to Dorico does work, but you must have run into an edge case. It’s difficult to figure this out, because we need a reproducible recipe. Any help from your side is greatly appreciated.

Thanks Ulf, that is what I suspected. I haven’t yet tried to reproduce the problem, but the facts I do know:

  • As I mentioned before, I’m on macOS (10.13.6)
  • Dorico 3.1.0.1021
  • I did NOT (at least knowingly) change the sample rate of the sound card while Dorico was open…
  • …however, in Audio MIDI Setup, I checked the settings for the various inputs and outputs. Built-in Output was set to 44.1 kHz, but Built-in Microphone was set to 88.2 kHz. Perhaps that could be related to the issue. I have other sound drivers installed as well (Soundflower and Pro Tools Aggregate I/O), but they were all set to 44.1 kHz.