Playback delay with VST and macbookpro

Hi, i have cubase 6.5.3 on mountain lion in a macbook pro early 2011 with 16 gb of Ram and a samsung 830 SSD. I am working on a project with fifty midi tracks. All the sample libraries are in a server PC running Win 7 (VSL special edition, LA scoring strings, omnisphere and kontakt 5) and don’t load the cpu or ram of the macbook. I have a lot of playback problems and cubase seems to respond with a lot of delays. ( the meters of the midi tracks and the mixer moves slowly, when i scroll during playback cubase responds with much delay) but the cpu usage is only 19% and ram is only 8 gb on macbook pro. There is a problem with discrete GPU of the Mac because i use an external 19" display connected to macbook or is a problem of the osx mountain lion and cubase…i have tested in 32 and 64 bit mode but the problem persists
Do you have any suggestion please?


I expect, you are using VSL VE Pro. I think, this is feature of whole your system. I’m using very similar system, and there is quite large latency. The reason is, the second one computer has to have time (delay) for compute all processes, and send it back to the main system. So this is not surprisingly, there is latency, for me.

I’m recording my tracks with Cubase’s internal, or NI Kontakt’s sounds. When I record all tracks, I switch it to the VSL sounds, which are routed by using VSL VE Pro.

Do you refer to playback latency when you play the parts on keyboards? because in this case i turn down the samples of my audio board RME to an little value (for example 512 or 256) and i have less latency (about 6ms) while i am sequencing parts…but i say that i have the problems when all the parts are already sequenced and i don’t play nothing anymore. I only playback the piece and during playback cubase seems to overload and respond with delay…if i open a menu this is most slow than normal and the meter, the scrolling, mouse click seems doing the same thing etc …seems like i have loaded a great number of audio plug in like Altiverb, Izotope, omnisphere etch directly into cubase session on a macbook pro, but nothing is loaded because is all hosted to a server running VE PRO 5…could i resolve the problems updating cubase to a 6.5.4 beta? or i don’t know…i’ll trying to use only integrated monitor, or running the project on other computer with lci express GPU…

I see, so this is not sound delay/latency. This is more like GUI delay, or like lots of precess, right?

What about your hidden process on your system?

Can you try to unconnect all of your MIDI tracks, and reconnect them to different software/hardware)? Lets say, make one isntrument with very light sound, and connect all sounds here. Then just play all MIDI data, and try to check behaviour of your Cubase and system.

Hi, i have tried to run the project on a Pc with an nvidia Pci GPU and only one display connected…seems that the problem persist, the GUI of the cubase responds much slowly while it’s in playback…can you explain me better what do you said me in previous post please? i didn’t understand well…thanks

Hi, i have another problem in addition…when playback the project the performance vst indicator display 100% asio stress…i hear also many “crunch and clip” from my monitors…this happen in the points of the song in which there’s many VST’s that playback together from the VEP 5. In activiti monitor of the macbook pro the cpu used is only 20% and 9gb is the Ram usage. Now i try to update the firmware and the drivers o my Fireface 800


First of all, increase buffer size of your sound card. Find Devices > Device Setup. In this window, find the name of your ASIO driver, under the VST Audio System. Click to the Control Panel button here. It displays Control Panel of the Sound card. Find Buffer Size or Latency parameter. Increase this parameter, confirm it, and try to start play again.

Try to optimize your system.

ok i have increased the parameter of asio buffer, i have installed the latest version of elicenser and the Cubase update 6.5.4. Increased also the buffer on Vienna Ensamble Pro 5 to 4 buffer and the playback seems works better. I don’t understand because with the fireface 800 i have a latency of 40 ms it seems too high…i have updated the firmware and drivers of audio card but the latency still remained the same.

Now the problem is the GUI that is still too much slower…i have tried to mixing all audio track inside VEP 5 (on the server PC) and i have routing back only 4 audio channels (strings, woodwinds, brass and percussion) in the cubase mixer (first were more than 100 tracks, 1 for each instrument) because I thought it might be too many stereo tracks that overloading the mixer cubase slowed down all Cubase functions during the playback … but the issue has remained… on the forum I saw that there is other people that after upgrading to version 6.5 or 7 had the same problem … it could be a bug in cubase?

It could be bug of Cubase…

Can you try to make a new empty project, with one MIDI track, which is not routed to any output. Try the GUI now, how does it work?

With empty midi project there are no problems, also when i oad 10 Halion sonic tracks, both in 64bit and 32 bit modes

Maybe are all latency problems that affects both the GUI and the Playback…

Do you know how can i try to optimize (balancing) settings with sample rate of my sound card (that can increase from actual 48k to 192k), buffer size of cubase (actually 2048 samples) and VEP PRO 5 server (Actually Buffer is 4)…

and if i try to change the vst audio system preference in the Device setup menu can obtaining better latency and VST performances? actually there are default settings :
Audio priority: normal
multi processing: actually is activated with disk preload of 2 seconds
Record latency compensation is activated
recording shift: actually to 0 samples

Latency Settings
In the Vienna Ensemble PRO Server Interface you will also find the Latency settings. This value ONLY affects the latency added over network when you are playing live.
We have applied dynamic latency compensation to Vienna Ensemble PRO. This means that your sequencer will automatically adapt to the chosen buffer settings of your Vienna Ensemble PRO Server Interface plug-in.
• Setting the Latency to “none” will synchronize Vienna Ensemble PRO with your soundcard, so that no latency is added – while very good for recording percussive sounds, this also adds a lot of strain to the CPU.
• Setting the Latency to “1 buffer” will add one buffer to your soundcard latency. If your soundcard latency is, e.g., 256 Samples, your latency when playing live will be 512 samples.
• Setting the Latency to “2 buffers” will add 2 buffers to your soundcard latency. If your soundcard latency is, e.g., 256 Samples, your latency when playing live will be 768 samples.
• And so forth …
Generally speaking: The faster your CPU and the better your soundcard, the more you can expect from
your system!

But when i have raised to 4 sample audio in cubase when i playback song seems doesn’t “crackle” anymore and asio performance decreasing at a normal value of 5-10%…seems that it isn’t only affect the latency when i play but also when playback sound…
Do you have any suggest about…?