Playback dropping notes (BBCSO)

I am having trouble with playback/recording of longer notes for some time now. I will only hear the beginning and a tail (often times “too late” musically) of longer notes while the audio in between will just drop out with a clicking noise. Here is an example:

https://app.box.com/s/3t4hybfjir9gsz8jkjguncb1zbaltom2

I am dealing with that specific problem for some time now and a RAM upgrade seemed to have fixed it but since today it is somehow back in a massive way. I am using BBCSO Core with the expressions map and the plugin itself seems to work fine, so for instance, if I play an octave on my keyboard it works perfectly fine but when I record the exact same notes with the exact same sample into dorico the sound suddenly drops out while recording and afterwards while playing as well.
What makes it worse is that it is completely random, sometimes it will play everything, sometimes only one of the notes while dropping the other, or the other way around or nothing at all and both will be dropped. That randomness drives me crazy because it did work after I got more RAM for a few weeks but now it happens again.
I’d be very thankful for any tips…

Welcome to the forum, @aelfric3. I’m sorry you’re having this problem. I know that BBC SO does seem to present more performance issues than other plug-ins, for whatever reason. Have you tried increasing the buffer size value in Edit > Device Setup in Dorico to see if that helps at all?

Thank you for answering. Yes, I tried several buffer sizes with different ASIO-drivers but that didn’t solve the problem. Long notes and multiple voices seem to increase the likelyhood of it happening, I don’t think I ever experienced it with an 1/8th or staccato note. But if its 2 ovtace notes over 3 bars with ties, it might occur but not if I remove the ties and play 3 separates octave notes.

Hi @aelfric3,
You could try this workaround changing the Spitfire Audio Player settings for BBC SO.
I had e similar problem like you. The guys at Spitfire Audio gave me this temp solution.
It works for me, but still it’s a temp.

I tried to “force” them to improve the performance of their plugin, but they said that I’m the only
one to complain, but obviously I’m not. So, I recommend you to inform them about your issue.

I hope this will improve your situation! :slight_smile:

Best wishes,
Thurisaz :slight_smile:

1 Like

@Thurisaz

Thank you for this suggestion, it seems a bit counterintuitive, but I changed the setting to these values and it seems to work so far, even though today, after a clean reboot, it did before as well. As I said it seems quite random sometimes. So I will have to test it for a bit, but nevertheless I was able to work again plus the settings reduce the memory load by about 2/3, which is a nice plus. :slight_smile:
I will see how the player works with the DAW later on but thanks again, I hope it keeps working for you as well and we have to pester Spitfire support a bit more :slight_smile: ::

2 Likes

I’ve added a post asking for some optimization update. I’m so fed up with Spitfire products that I don’t use them anymore (and avoid buying any other until they do something to make us work with them!)

1 Like

Small Update after testing the workaround for a week: everything seems to be working fine so far with these settings, even though it seems weird, that reducing Preload and Stream Buffer size helps. Maybe it forces the plugin to go into a more efficient mode?

1 Like

Same feeling here. It seems to behave better (although loading times are still painfully slow).