Playback Gets Stuck in Dorico 4

In Dorico 4, pressing P results in the playback buttons lighting up properly and the playhead becoming visible but it remains stationary, and no playback takes place. The program is fully responsive in every other way.

This happens with Dorico 3.5 projects opened in Dorico 4 in Windows 10, as well as 3.5 projects resaved in Dorico 4. Clicking at staves, rests and notes would occasionally produce playback, however with diminishing returns.

I found only one thread describing this issue, but reinstalling hasn’t solved it for me - I also reapplied the template, applied Silence and restarted, etc - no dice. Appreciate any help, so far Dorico 4 is unusable.


I’ve had this a couple of times but always after some kind of crash involving the audio engine not shutting down properly. Are you absolutely sure that there is is no audio engine still running in the background when starting Dorico? I assume you’ve also restarted your machine. And this sounds like new behaviour as your previous posts suggest you’ve been using Dorico 4 for a while now and I imagine you’d have spotted this immediately if it had been present from the start but of course I may have missed something here.

Also, please do in Dorico ‘Help > Create Diagnostics Report’ and post the corresponding zip file here. That will give me the best overview to help you further. Thanks

@ebrooks , thanks for the data you have sent. Two things to note:
First, your output mapping is set up so that Dorico plays out via ADAT 7 /8, is that expected and what you want?
Second, there is no VSTInstrument loaded with you except for DoricoBeep (the plug-in that produces the sound for the metronome.) I don’t know how you got into that state. But how about if you go to Play Mode and then choose from the menu Play > Playback Template, and then the HSSO template, what is happening then?
If you click on the e-button to open the HALion window, does it come up then and what sounds is it loading? It might well be, that you’ve stuffed your playback templates somehow, but lets find out.
Btw, what happens if you start a new project, e.g. solo piano? If you enter some notes, does that play back correctly?
Sorry, questions over questions…

Thanks @Ulf for such a fast response. I am only getting MIDI out of Dorico and no VSTs, that’s the reason the Beep is the only sound generating component loaded - it’s used for getting the playback timing aligned. Everything works perfectly in 3.5. I will try your other suggestions and will come back.

Ah, okay, you only use MIDI. Still, it should work. What if you go to Edit > Device Setup and change the sample rate to a different value, wait a few seconds and then switch back again to the old rate. If you then close the dialog and press Play, does it work then properly?

@Ulf Unfortunately, this doesn’t help - I press P at various spots and the playback only works maybe 1 out of every 10 tries, or even less than that.

EDIT: Switching audio device to “generic” ASIO driver and then additionally changing sample rates also doesn’t work.

And what if you temporarily disconnect all unnecessary MIDI devices, like e.g. your CMCs?

Thanks again @Ulf I tried that, also no luck.

However, I discovered something else: I can get more reliable playback if I go into Play Mode and put the playhead directly on a marker. As an experiment, I removed it and now I can get playback if I place the playhead on certain specific bars within each of the flows. Starting to suspect some kind of corruption in markers or timecode…

EDIT: Nope, it’s on and off again even on those bars.

To be honest, I’m running out of steam. I asked my colleague if he has some more ideas; I’ll come back here soon.

@ebrooks , some more things to try, please.
So Dorico 3.5 works and Dorico 4 not, right? Do you happen to run them both in parallel? Because that definitely won’t work, you have to run them exclusively, one at a time.
And what if you click on single notes in the score, do they get sent to your external instruments?

Furthermore, please try and close any other app that is running and then start Dorico 4, still the same? What if in Dorico 4 you start a new project (e.g. a simple piano project with just some arbitrary notes) does that play back with you? Does the play cursor move?
And have a look at the far most right bottom of the Dorico window. Is there some red triangle shape displayed. If so, that means there is some trouble with the audio engine.

1 Like

Hi @Ulf and thanks for your suggestions. Indeed, I have reliable playback in Dorico 4 if I create a new project! Adding more players from my template does not disrupt or prevent playback.

However, some instruments are incorrectly recalled: (eg Clarinet A players ends up going to Clarinet Eb VST instrument). Importing an individual flow from Dorico 3.5 project corrupts playback. Even copying just the notes from that imported flow into a freshly made one breaks playback. Playback works reliably only on brand new project for some reason. Should I be thinking of recreating the template for Dorico 4?

Please send the project file to ‘u dot stoermer at steinberg dot de’ and I can try and see what I can recover.

To update (and close) this thread - from exchanges with Ulf, it appears that the cause is likely a corrupt 3.5 project file. The potential workaround is to export data from 3.5 as XML or MIDI and then attempt to add it to a fresh 4.0 file.

Many thanks to @Ulf for his patience and help.