Playback in Dorico Pro 2

I recently upgraded to Dorico Pro 2 on OS X El Capitan (10.11.5), and while most features seem to work normally, playback has been having some strange errors. When I try to start playback from the beginning, it starts somewhere in the middle of the piece. After a couple restarts, I can eventually coax it to start from the beginning, but it still won’t play where I would like for the rest of the session. The playhead is moving, however, it’s not moving at the same position as the music being played. When I try to start playback from a specific location using the ‘P’ command, it always starts towards the end of the flow regardless of what location I’ve selected. I can’t find any consistent pattern between where it’s actually playing and where I want it to play–it’s not consistently 20 measures ahead or anything like that, it’s just always farther into the piece than where I’ve selected. I’ve already tried deleting the VST instrument folder in ~/Library/preferences, to no avail.

Any thoughts? I would rather not update from El Capitan if possible, but I know that that’s eventually going to have to happen.

This is something that can happen if the sample rates changes outside Dorico. Try changing the sample rate in Edit/Device Setup.

I just tried changing the sample rate and restarting the program. It plays back normally from the beginning the first time, then everything seems shifted forward in time, with only silence if I select a point later in the piece. The time position in transport and the playhead are aligned, but the sound doesn’t match. I also forget to mention that I’m working on a file created in Dorico 1.

Does this happen with all projects or just one? If its just on one project can your attach it here?

I tried another simpler project and it seemed to work fine–here’s the project in question. It was too big for the forum, so here’s a link to google drive:

I don’t know if this would apply, but in Sibelius, playback would often be corrupted if the repeat structure was not correct, i.e., a repeat sign that has nowhere to repeat to, etc. Just a thought, as things can play ok from the beginning, but once in the “trouble zone” the playback engine can get confused. Possibly the problem, here?

This appears to be a bug that we only discovered in the last few days, and I’ve been working on today. It’s caused by a bit of a grey area between several conflicting requirements.

Firstly, the ‘why’: the video and timecode features require a concept of overall project time from all the flows in sequence, eg Flow 1, , Flow 2, , etc, so that each flow knows where it is in ‘project time’. This is all fine for simpler situations where you have a full score and parts containing the same sequence of flows. However, if you have layouts that contain a different sequence of flows then it introduces a conflict, because these have a different timeline. If you are using flows to hold ideas or versions, as you are here, then you also want to be able to put them in a custom layout and play them, and you don’t care that the flow isn’t in the Full Score layout. However Dorico does needs to have a place in ‘project time’ for it.

Furthermore, there was a ‘fix’ I added for the case of audio export having lots of silence at the start which I think may have broken this case a bit more because that then shifts the start time back to zero if the first flow isn’t in the layout. This unfortunately then means that Dorico can’t display the correct position when playing back.

I think you should be able to work around it in a couple of different ways. Firstly you could try rearranging the order of flows in Setup mode so that the ones in the full score layout appear first, or so that the ‘used’ flows appear first in the list and the unused ideas come afterwards. Or try making the default full score layout a dummy one that contains all flows. Or bind some keystrokes to the ‘Go to next/previous Flow’ commands and try hitting those if the playhead seems to disappear.

FWIW, my head is spinning trying to make sense of how we can best deal with this conflict in the future. I have improved the behaviour in our current development build where I can now switch between all the layouts and play back each part as expected, so this should be in the next update.

Hi, Paul!

(I want to say first that I have not used the video feature in too great a detail yet…)

I’m a bit surprised that there is something like a main layout that Dorico’s timecode feature depend on. As I understood it, layouts are just some loosely defined containers for flows and players.

I would have expected Dorico to attach a video to a layout, and no mather which flows are in this layout, the video + music would always play together. So if the same video would be attached to another layout which holds less or completely different flows, the video would be in sync with these flows. (And obviously you would see a different video+music+timecode combination as in the first layout.)

Am I completely wrong?

Almost - videos are attached to flows rather than layouts.

Oh, thanks for putting that out. I must have missed that in the very beginning :smiley:

Thank you for addressing this so quickly! Even though it’s not ideal, I think it’s a testament to how logically Dorico has been structured that there are so many non-invasive options for work-arounds.

I’m a big fan of the ideas panel in Sibelius (as you can see by my workflow), and while I was initially looking for something similar in Dorico, I’ve found flows to be even better due to their flexibility. It still might be nice to have a way for users to define ‘sketch’ type flows and somehow take them out of timecode considerations entirely. Often I have sketches in a piano staff which I then orchestrate, or else I split a section of music into a flow before I make changes. Being able to right click a selection and immediately split it into a new flow would be lovely.