Playback: Just when I thought I could start liking Dorico (Argh!)

I remember when I first tried out baby Dorico. It was pretty, but sound was missing. I thought, “Well, it’s new. They’re getting their feet wet. I’ll try it some other time.” Every time there was an update I thought, they’ll get the sound right this time. No joy. Dorico 3.5 seemed like everything was together, particularly because Dorico was able to use NoterPerformer 3.

So I get the free upgrade to D4. And I get the free upgrade for Notation Express for Dorico 4, too. I don’t know how the latter has anything to do with the sound of the former, but I mention it because that’s when the sound trouble started. I get ZERO playback even though everything seems to be loaded properly. At first, NP3’s interface didn’t even show up. After restarting, then it did. Even after making sure that the Playback Template was NP3, I still get no sound. Deja vu all over again.

Any ideas? I had come to expect playback problems before D3.5. It’s upsetting that it’s an issue again. I just fired Dorico up because I had installed the Notation Express profile for D4. Otherwise, I’d have no reason to complain because I’ve been using Sibelius 2021.12. Serves me right? LOL

Please do Help > Create Diagnostic Report and attach the resulting zip file here so we can take a look.

Where would I send it to? I tried uploading it here, but the file is 11 MB (too big).

Hi @thecoast , if you unzip the, you see 4 subfolders. You could zip up each one individually and then attach here separately. If one of them is still too big for upload, instead you can send it to ‘u dot stoermer at steinberg dot de’. I’ll pass it on to Daniel.

1 Like

Following Ulf’s suggestion except that there was trouble uploading the three small zipped folders. I sent the Dorico file to Ulf.

Thanks for the data, @thecoast , and I can clearly see what the problem is. The ASIO driver is not “seeing” any sound device that it can stream out to.
Please go to Edit > Device Setup and then click on the Device Control Panel button, a new little window will open. In there you have at the top an option saying something about ‘exclusive access’.
If you toggle that option, does then some output port get listed in the middle of the window?

That’s the thing. It shows no output. I didn’t have this problem before. What could cause it? NP loads and you can see their mixer panel. It is very discombobulating.

Hi @thecoast , may I ask you to watch this tutorial video from around 13min 40s as it deals with exactly that case.

Thank you, @Ulf . I think I’ve seen this before. However, the Steinberg case I opened got me a solution that didn’t make sense but worked:

"In the play tab, play menu, there is an option for Playback templates. Can you apply the silence template, close the window, and then immediate go back to the templates and apply the note performer template?"

I didn’t have to go back to the Playback Templates but everything else applied. My response was a heartfelt thank you but I also wanted to know WHY/HOW the problem happened in the first place and why/how the solution worked.

My favorite new feature is the piano roll window available under write mode. So cool.

Anyway, happy camper again, even if it’s not my go-to software yet.

@thecoast , well, if it works again, cool. But to be honest, I have no idea why the other advice should work. If, then only by accident, I presume.
Anyway, you are a happy camper again and you know where to find us should things go wrong again.

1 Like

Here we go again. I’m convinced that updating the Dorico 4.0.10 Notation Express 2.1 profile for Stream Deck must mess with the sound because that’s what happened with the Notation Express 2.0 update in Dorico 4. This time I tried the fix sent by the Steinberg/Yamaha support team. (I didn’t know Yamaha owned Steinberg–and since 2005!) Anyway, the fix didn’t work. Submitting another trouble ticket. Good grief. :roll_eyes:

I’m really not sure how installing a Stream Deck plug-in could have any impact on Dorico’s sound. What fix did you try on this occasion? It’s OK for you to come here and moan, of course (it’s good to have a moan sometimes) but if you would like us to help you, please let us know what you have tried to solve the problem.

I will perhaps also find your previous thread and move this post there.


I’ve moved the new post to this existing thread to keep the problem reports together.

Per @Ulf’s previous advice, can you go to Edit > Device Setup to see whether an appropriate ASIO device is chosen. If it appears to be, click the Device Control Panel button in the dialog to show the Generic Low-Latency ASIO Device window. Check whether the option for exclusive control at the top of the GLLAD window is set, and try changing it.

If everything appears to be in order there, start a new project and add a single instrument, then add a few notes. Do you get sound? If not, go to Play mode, then choose Play > Playback Template and try applying the HSSE+HSO (Pro) playback template. Do you now get sound?

And please do Help > Create Diagnostic Report and attach a fresh set of diagnostics so we can take a look and see what might be going on.

I agree, @dspreadbury. I don’t think the Stream Deck plug-in update should have anything at all to do with the sound reproduction, but it’s the only commonality between the two similar events. The loss of NotePerformer functionality doesn’t make sense either with or without the update.

I’ve tried all of these things. The difference now is that the NotePerformer mixer doesn’t even show up when I click on the e button. However, it does play the piece when I switch to HSO Pro. Already created the Dx Report.

Perhaps you could attach it here, then?

Here you go, mate. Thanks.

Dorico (487 KB)

Hi @thecoast , I don’t know how it happened, but now NotePerformer is on the blacklist, i.e. the VSTScanner found something is wrong with it and put it on the blacklist. A blacklisted plug-in gets ignored then and won’t get loaded anymore.
Let’s try something simple then:

  • Stop Dorioco
  • Go to C:\Users[yourname]\AppData\Roaming\Steinberg\Dorico 4 AudioEngine_64
  • In there delete the two files Vst2xPlugin Blacklist Dorico 4 AudioEngine.xml and Vst2xPlugin Infos Dorico 4 AudioEngine.xml
  • Restart Dorico, create a new Diagnostics Report and post here

Thank you very much.

Here you go @Ulf and @dspreadbury :
Dorico (500.7 KB)
Much smaller diagnostics file. Hm. At least if you don’t know how it happened, it might mean I haven’t totally lost my mind. OTOH, that might be wishing for too much. :sweat_smile:

Then we have to try something more technical. Please follow these instructions:

Press the Window key and then “cmd” without the quotes. Then the enter/return key and a little black window shall open.
Copy and paste the following command (this time with the quotes):

“C:\Program Files\Steinberg\Dorico4\VSTAudioEngine\Components\vst2xscanner.exe” -p “C:\Program Files\Common Files\VST2\NotePerformer64.dll”

and then enter/return again. Is some output coming out? With the mouse highlight everything and press the enter/return key to copy it to the clipboard. Then paste to a reply here.
Also do type the command


and yet again enter/return. Now a number shall appear. What is it showing with you?