Playback not respecting clef

Hi all. I am fairly new to Dorico and this is my first post. Hope you can help!
I am using the Bass clef with the 8 below it
Screenshot 2023-08-02 at 11.46.07
It is a piano part. On playback it is not sounding an octave down although I have told Dorico to Respect octave indicator in the Notations panel
Can you please advise?
Thanks in anticipation …

Hi Ross – Welcome to the forum!

I tried this with “Respect octave indicator” and it works for me. Notice that when you change that setting, the notes in an octave-clef jump by an octave (just like if you write an 8va line). Maybe you have to move the notes down an octave, to where you first wrote them?

Thanks for replying Mark. I took your advice and it worked. Thanks for your help. Much appreciated!