Playback not working

I’ve not used much playback until now. About half the time I start Dorico up I have no sound. I have sound from Pianoteq’s VST window so no midi is getting through to it. Noteperformer is also silent. If I go to Play: Playback template and reset to Noteperformer, then load sounds for unassigned instruments I get sound back some of the time. I don’t want to do this because it wipes instruments other than note performer. Restarting Dorico gets sound back about half the time.

Any suggestions?


Sounds like it might be a driver issue… 1st thing I would try is to go into Edit > Device Setup and where it says Asio Driver try different options. Also experiment with the Sample Rate.

I have sound from the plugin within Dorico if I play the on screen keyboard. But no MIDI seems to be going from Dorico to the plugin.

And the Endpoint setup is set correctly?

Yes. About half the time restarting Dorico clears the problem.

Hmmm…! That is very odd indeed. Well there’s nothing like good ol’ fashioned scientific investigation to nail down a problem:

1.- Does the VST always make a sound when playing the on screen keyboard, if yes then
a) is the instrument set up correctly in the play window? (both the endpoint and the instrument config)?
b) is the mixer muted? An accidental key combination press might be muting/soloing the channel?
c) is the VST on the Endpoint configured to use a specific expression map or the default?
if no then
a) is soundcard set to “allow applications to take exclusive control of this device”?
b) and “Give exclusive mode applications priority”?

We’ll take it from there… Ah! Also, are you on Mac or PC?

When playback isn’t working, try creating a new project with just a single instrument (e.g. piano) and add a few notes. Do you hear the notes as you input them? Do you hear then when you play back? If the answer to either question is “no”, save the project and zip it up, and do Help > Create Diagnostic Report, then attach both the zipped up project and the diagnostic report zip file to a reply here.

Bollen, thanks for your help.

  1. Yes
    a) yes
    b) no
    c) default
    On Mac, so core audio, not going through an external output. Also the on screen keyboard is within Dorico.

Daniel, I’ll do that.

Thanks both.

That’s so weird but this exact thing just happened to me! I was doing some tests for another thread, for this I had to forcefully crash Dorico using Task Manager. When I reopened Dorico it offered me to open the file that was auto-saved. It opened with everything correctly configured: A simple Piano routed to Kontakt, I pressed Play, Play from, Replay, etc. nothing happened! I pressed on Kontakt’s own keyboard and it played loud and clear. I used Kontakt’s own MIDI Monitor and it was receiving no signals from Dorico…(?)

1.- I replicated the experiment by crashing Dorico again and got the same result.
2.- Daniel I also created a new project as per your instructions and it worked fine. I then went back to the restored file and it still didn’t work.
3.- Opening the original file (not the auto-saved one) also worked fine

Another final thought, when I spend a lot of time without playing anything in Dorico it often cuts off when I play again after say half an hour or more. Almost like the plugin goes to sleep or something…

Just for info…
Mine definitely wasn’t after a crash nor from a backup file.
Weird that it’s happened to you.

Hi Daniel,

Interesting. I created a new project with just piano. Played back fine. Switched back to the non-working project and that played back too.

Does the non-playing project still refuse to play back if you e.g. open it directly after opening Dorico, even now? If so, please zip it up and attach it here.

I find Dorico to be quite finicky about playback on my Windows 10 systems. I almost always have no sound after starting, but if I go to the Play tab and select (even the same) playback system on the righthand side (under VST instruments) it usually comes on. Doesn’t seem to matter whether it’s NotePerformer, Pianoteq, or Symphonic Orchestra, they all seem to behave similarly.

Addendum: I was just in a state with NotePerformer where it would play back when I clicked on a note in Write mode, but when I hit play I got nothing. Seemed to get fixed when it when to the Playback Templates menu and clicked on NotePerformer (even though it was selected). The VST helper window went away and didn’t come back, but I got playback, so I counted that as a victory.