Playback on "old" MacBook Pro

Can I hope that playback on my MacBook Pro 17" late 2009 will get smooth like it is in Sibelius as Dorico matures?
I have upgraded to an SSD but at the moment Doricos playback on about 10 staves is poor.


You might want to try experimenting with the settings within HALion Sonic SE itself – it has some settings for disk performance, maximum polyphony, etc., and changing those settings may well improve matters on your system.

Unfortunately it didn’t help what I had tried so far. Which setting could probably improve the playback?

Can you describe what you are experiencing? Are notes cutting out? Is it slow to start playback?

The playback gets interrupted. Like breaking up and continuing. As if you listen to a radio and the connection is bad, so it gets lost and comes back again. it seems as if the playback device gets overloaded with data not able to reproduce them for a moment and then comes back to sound.
Hope these descriptions help.

Try increasing “max voices” in the Options panel of the HALion player to the max possible (1024)

Also, in the Edit panel, select each instrument and set the Polyphony to the max (128).

If you have string instruments playing fast notes, there are a lot of overlapping samples that produce the decay of each note. Even a solo violin instrument playing a single line of note at a time might need polyphony values as high as 50 or 60 sometimes.

AFAIK setting the “max” values higher than necessary doesn’t “waste” any significant amount of computing power. If you look near the “Steinberg” logo at the top right of the player, there is a field marked “#”. When you play back the score, that shows the number of voices being requested for playback - but unfortunately I don’t think there is an easy way to get that number for individual instruments, only for the whole score. (Using the Mute and Solo buttons to select one instrument at a time doesn’t make any difference, for example)

Thank you very much for the hints, Rob!

It got a bit better when I set the voices to maximum in options and all strings parts to 128 Polyphony. But as soon as the tempo increases (second flow) not even one violin alone was playing correctly. Interrupted and skipping notes.
Very poor. What a pity.

I have no problems with even larger scores in Sibelius. After the upgrade to SSD I can even use Sibelius Sounds (not the lite version).
But in Dorico so far no chance.

Will this get acceptable in future, Dorico team?

See, I like Dorico in many aspects and Sibelius I mean under the control of Avid has no future as it seems. Promises made and broken and left alone. (I mean Avid!)


in Halion player you can replace instruments with a gm variant.
These are very lean samples, so they should make playback easier.
just type ‘gm’ into the instrument field, and you’ll see what is possible.

Can you post the Dorico project (or at least a small section of it that shows the problem) here?

Then other people can check if it’s something weird with your particular score, or a problem with the way you have Dorico and Halion set up.

I’m running on a pretty powerful Windows box so that’s not directly comparable with a fairly old Mac, but playing a 10-stave score hardly registers any load at all. From the CPU usage in the system performance monitor, I can’t even guess which cores Halion is actually running on.

Playback doesn’t use a great deal of Cpu (in Dorico itself). The HALion samples are quote lightweight so they shouldn’t add substantially to the load. You may need to increase the buffer size though. Also try doing Apply Default Template which will recreate the audio engine configuration with the current recommended defaults.

I mean this with the utmost respect, but we also have to remember that in technological terms, a computer from 2009 is “ancient”. I say this as I myself type from a 2010 MBP so I’m not far ahead of you. My personal guess is that you’d be better served by more ram (if it can accept it) than an SSD. SSD’s are going to help with things like boot times but less so when it comes to day-to-day operations. How much ram do you have? I purchased mine with 8gb and I have no problems. If you only have 2 or 4 GB (as would not have been uncommon at the time) that may be the culprit.

Thank you for the reply. I also have 8GB ram. The maximum for my Book.
I would have upgraded my MacBook Pro if apple had another newer 17" in their offer.

The trick was the increasing of the buffer size. Thank you Paul!! No it’s working as it should.

Many thanks to all of you!