Playback problems - 4-5 seconds until Dorico plays back


I have two computers for Doric use. One is a Macbook Pro, Doric works just fine without any problems or strange behaviour. My stationary computer is a Mac Pro equipped with 2,66 Ghz quad-core Intel Xeon, OS X 10.11.6 (El Capitan) and 32GB ram.

Everything beside playback works ok. Playback is extremely slow. When I press play it takes ca 4-5 seconds until playback starts. What could be the problem? Any ideas how to solve the problem?

Best wishes!

Have you read the two pinned threads entitled “Can’t get sound on playback, or other audio problem? Check out this video” and “Frequently asked questions: try this thread first”?

If so, great! Let us know that we can cross the usual contenders off the list.
If not, I despair. They’re pinned to the top of the forum and couldn’t have much more obvious titles…

I’ll check the video. Since I’ve got two computers, one with problems and one without problems, I posted this question to see if anyone else had similar problems. There’s no need to be ironic.

The Video pianoleo pointed my attention to was very helpful, but not regarding my problem. I’ve tried every setting possible without any change.

When I press play it takes about 4-5 seconds before playback starts. So, is there anyone else who might have a constructive suggestion how to solve this? It’s most irritating and makes the work flow feels like slow motion.

What physical devices are connected to your Mac Pro? I’d guess that some driver is acting badly causing this delay.

Nothing connected at the moment. Just line out from the computer. I have RME Fireface connected, but not turned on. The RME drivers are very solid and have never caused any problems. On my laptop, where Doric works just fine, I have the same RME drivers installed. I also have M-Audio Keystation Mini 32. I’ve tried to disconnect it without any change.It’s very strange. It’s like Doric needs to think for a while before starting the playback.

You don’t have any printers or other external devices that aren’t audio related? I’d unplug everything including your audio interface, reboot and see if the problem goes away. If it does then plug stuff in one at a time until the problem comes back.

Also, where is your elicenser plugged in? Directly on the CPU box or in the monitor port or somewhere else? Try moving it to a port on the computer if it’s not there already. Or try a different USB port.

How many Players, Olfdan?

Does it always happen - no matter how many?

And no matter which?

IOW is there this same delay with all the suggestions above, a new Dorico project and just, say, one piano?

Dunno about Macs, but a friend of mine has all sorts of related problems running a 4k monitor on his mac pro…


Thanks for your suggestions. Nothing connected to the computer besides what I mentioned, the printer is a network printer. 2 players or 18, doesn’t matter. Same thing happens. If I move around in the score the delay goes between 2 to 5 seconds, a few times it starts directly. If I then move to a new position in the score, 4-5 seconds delay. It doesn’t matter if it’s a new or old score. I tried to move the e-icenser to a different location, usually it’s connected to the keyboard. Tried directly on different ports on the computer without any success.

I’m beginning to think that my computer is to old. Could that be the case? It’s from 2009, running perfect.

I use it a lot with both Pro Tools, mixing really large projects (big band recordings), and Ableton Live. Never any problems. I’m also using Sibelius a lot, when waiting for Dorico to be fully functional, without any problems.

My money is on the printer even though it is a network printer. The OS on the Mac Pro is older than on your MacBook Pro right? So the networking and printer drivers are older.

Disable your network. If it’s wifi, just turn off wifi. If it’s ethernet, unplug your ethernet cable. Reboot.

I’m not sure which OS version is supported on the Mac Pro, But are you on the latest supported version?


Yes, you’re right. Laptop is Sierra and Mac Pro El Capitan, latest possible. So never on my laptop. I’ll try your suggestion tomorrow. It’s not possible to update the system later than El Capitan on the Mac Pro. It’s getting closer to a computer update…


This is a really strange one - I’ve not heard reports of this before. Even if you have an old machine I wouldn’t expect that you’d have such a delay, especially if you have this problem with a small score with only a couple of instruments. If you haven’t done already try rebooting. One other thing could be to try deleting the Vstaudioengine directory in ~/Library/Preferences, which will cause the audio engine to re-initialise.

Since the update 1.2.10 I’m watching it also (pc).
In the period of the delay, I could not locate special burden of memory, cpu, hard disk, network, etc. Also no other programs ran in time, also no automatic update of Windows. Sometimes the music is played instantly, sometimes after 4-5 seconds.
Another point is the stuttering when playing with many instruments (orchestra). I worked all the time with a one core (in Halion Sonic, options). Improvement came only after activating all cores.
However, the delay while starting playback has remained (few instruments: piano+violin).

If you have that problem with delayed problem, could you please create a simple piano project with just a dozen arbitrary notes, press Play, wait for let’s say 15 seconds and then choose from the main menu Help > Create Diagnostic Report. That will create a zip file on your desktop with all sorts of logging data. Please send it to ‘u dot stoermer at steinberg dot de’. I can’t promise that I will find something in there, but this is really the best way to get more insights.
As Paul said, this is most curious and we never heard about so far, so we want to know more about.


So, now I’ve tried the following.

Disconnect everything, that is turning of wifi also. No change.
Deleting the Vstaudioengine directory in preferences. The delay did get a little shorter, but is still there.
Turned everything on, connected my RME Fireface, keyboard etc. No change.

Ulf, I’ve emailed you a diagnostic report.

Thanks for looking in to this!

Hi guys, thanks for the data. Unfortunately, in the log files I can’t find anything unusual. I have to talk to other engineers, what else we could check or suggest. Stay tuned.

Ulf, I suspect the cause of the delay is in the BIOS of the computer. Due to the attack of “Meltdown & Spectre”, the bios have been changed (new microcode).
Dorico 1.2.10 came in February. I have installed a new BIOS in February too.
After updating the BIOS, the function of the cache is not so power full.
Trade journal writes, that caused 2 to 10 percent loss of power.

I wanted to make an experiment with my old BIOS, but it does not go any more.
The last BIOS version (the included loader) is no longer backward compatible.

I think it’s incredibly unlikely that this is anything to do with the bios.