playback problems cubase 5 mac


I have a problem with playback in Cubase 5. When i open a project most of the time I have no problem but sometimes there’s glitches in the audio witch seem to come from nowhere. When the glitches happen one of the cpu meters goes red for a very short time while when there’s no glitches the cpu stays around 2 - 5 %. This seems irrelevant the the number of tracks I simultaneously playback (i have tried with over 40 and with 1 and like i said sometimes there’s no problem sometimes there is). I use this exact same setup on 3 different systems and i only have this problem on my macbook. The other two pc’s are running Windows 7 and are working fine. I use the same hardware with all: a MOTU Ultralite (old version).
I have tried different settings with the audio priority, different lengths with the disk preload and turned on/off the multiprocessing option, this doesn’t seem to affect the behavior. Further more i am not sure how to change the I/O buffer size on my new mac with my MOTU but then again I don’t think that’s the problem since the glitches would happen at a regular base (in all projects each time I open them) and not on a random base as it happens now (sometimes no glitches for a whole project sometimes just one or two sometimes just too much to listen to). To be absolutely clear the glitches don’t happen all the time and are always in different places when they happen so i’m 100% sure it’s not in the audio itself.

To be honest i haven’t done days of research on this so please spare me if there’s already a post about this particular problem. I have found some posts about playback problems, none of them seemed to resemble my problem nor be a part of the solution.

Thx in advance,


Cubase 5.2.2 build 637
Macbook Pro
2.4 GHz core 2 duo
4 GB 1067 MHz DDR3
MOTU Ultralite (old version)

From your description it DOES sound like it’s a buffer size problem, incidentally the meters you are referring to are NOT CPU meters, they are ASIO and HD usage meters, the top one is for ASIO and the bottom line for HD usage. this is a VERY common misconception.
It would be worth hitting your manuals to see how to change your buffer size as this is something you really should know how to do regardless.
The first thing to do would be to try this and then if you have the same problem at various buffer sizes to repost.

Aloha J,

To change buffer settings go to:

Menu->Devices->Device set-up->Control Panel->Buffer Size->Samples


Ah I see, I didn’t know about the meters but for some reason i automatically assumed it was for cpu since there are 2 and my computer has 2 cores as well. I should check my facts before posting sorry about that.

Ok thx for the reply’s i will try it with a different buffer size. The reason i didn’t is because in the past i have tried a lot of different buffer sizes to determine what was best in terms of low latency -> high quality (no ticks). This was on windows however and maybe it works differently on mac since on windows when you set it too low it will always give problems (constant ticks in playback) as opposed to my problem right now which is on a random base like i explained.

Thx again i will try it out and I’ll let you know how it works,


Ticks and ASIO overload are both (audio card + buffer size + number of buffers + computer capability) related. But the bottle neck of data, is slightly different. The answer to both is to increase buffers size and number of buffers until the problem goes away. It’s just like taking aspirin for muscle ache and headache. Same stuff helps both problems.

Thanks for this advice! very useful information, apparently i was wrong thinking it had nothing to do with the buffer size. I am still testing hopefully this fixes my problems.


Another important thing …
Buffers actually have 2 values that impact the performance of your audio interface. Some interfaces only show you “number of buffers” ie 128, 512, 1024 etc… The size is either fixed or dynamically allocated. Some interfaces let you set both the size AND the number of buffers. Interface Latency = size * number. Some interfaces even let you control some of the deeper stream settings.

So there are all kinds of problems associated with the buffers on your audio interface.