Playback Settings 9.5.15

Hi all …

I finally installed 9.5.15 (haven’t had time up to now). Liking it a lot and it’s rock solid.

I did the import settings on install and that pretty much worked fine.

With 9, I could switch between sample rates and different tabs with essentially no audio lag before playback. I still can.

But in 9.5 there is a long lag if I am playing a 96kHz file and then play a 44.1kHz file…

Because everything still works exactly as it should in 9, I conclude I must have a setting “wrong” somewhere.

I’ve screen shot the settings in 9 and it looks like its all the same in 9,5.

Nothing in the system is different of course. RME AIO card Windoze 10 Professional 32GIG of brand new ram.

Thoughts?

How long that lag? There is no change I can think of.
If you want the minimum lag, you better have to use the Resampler plugin (to output a constant sample rate), because in that case, there is no driver reset.

And a suggestion to add to that: I always have a resampler in the Playback section to easily play files that don’t have my most used sample rate. It’s mostly in off, but makes it so much easier to switch (also because in my case switching sample rate can be complicated).

Over 5 secs There must be something going on with the RME side oi things that I’ve missed.

I’ll explore this further when I get the chance.

Thank you for the clarification.

Here with my RME device, I estimate the switching to take somehow 500 / 700 ms.

Thank you again … almost instant as well on my system on 9. Something here for sure … not WL.

BTW, I really, really like 9.5. The new Spectrogram is very good. Feels rock solid. Congratulations!

BTW, I really, really like 9.5. The new Spectrogram is very good. Feels rock solid. Congratulations!

Thanks, big efforts spent there :slight_smile:

I also have way more lag when switching between 2 files with different SR’s. In V9 and before it was pretty much non excisting, now with 9.5 it takes about 2 seconds which is way too much. I’m running a Lynx Hilo which is pretty fast when it comes to swicthing samplerates.

I’m sorry to say it and I wish it was different but i’m afraid I have way more bugs and strange issues then in V9 and decided to go back again to that version. These issues first need to be solved before I can actually start working with it. I mean metering/cursor lag (an attended customer this morning really fel of his chair when he noticed), not working right mouse button = restart wavelab (same atteneded session…) and this problem.

Agreed - I used the spectrum editor quite a bit on a recent project - is really amazing. Thanks so much PG! :slight_smile:

Do you have some more involved settings or plugins when you see this delay? I haven’t really ever seen this problem and I must say that my RME HDSPe AES card handles sample rate changes very quickly and smoothly in WaveLab. My Lynx card was also OK.

I don’t have anything going on in the global master section or any plugins because for this demo these are mastered WAV files (ignore the mono audio capture from the video software).

Here’s a video of me switching between 3 different WAV files that each have a different sample rate:
https://www.dropbox.com/s/lmff3edb0420fao/WL9-5-15_RME_V2.mp4?dl=0

Everything is fast and smooth.

I wonder if perhaps some plugins or a clocking setting is the cause of your longer delay when changing sample rates. I always use the internal clock of my RME card. That being said, even when I do have some plugins going in the montage, I don’t seem to get a delay if I try to play another file of a different sample rate.

This problem was never there before v9.5, so it is introduced since then. It has nothing to do with pugins or whatsover.

Right, but it could help narrow down where the new issue is for you in 9.5. It somehow must be more specific to your setup than a general issue for all users.

This problem was never there before v9.5, so it is introduced since then

For me there is no difference between 9 and 9.5 on the same system, with my RME system.
Do you mean there is a difference with you? (excluding any plugin from the test)

Philippe

I can say that in my case, the issue is not related to plugins. I save each project as a its own .wpr project. That identical project in 9 works perfectly. The same session in 9.5 there is 2-5 sec delay. No plugins in either case. Identical configuration. Identical .wpr

I conclude that this is something I have yet to identify in my system. There is nothing to suggest that it has anything to do with WL and I never thought it did.

This computer is connected to the internet for “dongle” and installation purposes only. It has Windows Defender installed. We think someplace like this would be a good place to start looking because it “feels” like something is blocking the message to change the sample rate settings. In the “old” days of ProT*ols, security programs caused all sorts of problems and on my last computer a certain security system caused general weirdness.

It could help to get diagnostics. Please do this:

  • Click on the File Tab, then on Preferences
  • Now press Alternate and click on the Global button
  • You can now see a tab called “Diagnostics”, at the right side.
    Click on it.
    Now click on “Allow Logging”
    and in the field “Log Codes”,
    select:
    Log.AudioStreaming

Now come back to audio file or montage.

Start the application:
C:\Program Files\Steinberg\WaveLab Pro 9.5\Tools\Tracer.exe

Start playback with a 44.1 file, then switch playback to a file with a different sample rate.

Some log data will appear in the tracer window. Thanks to the time stamps, I could be able to know where the lag comes from.

When you don’t need logging, uncheck “Allow Logging”, which eats a little bit of CPU.

Thank you … I will do this after this session. I appreciate your concern. Especially as I am sure it is not WL.

Hi PG …

I have to report that the system has “cured” itself. When I went to do what you asked, everything worked perfectly … just as in 9.

The only change that I can identify on my system was an update to Windows Defender … update 19 December 2017.

As you have been very kind to me on this issue, I spent some time trying to recreate the issue using plugins that I typically use. Just in case another user encounters a similar problem.

To my surprise, Sonnox Limiter(current version) in native VST (NOT VST 3) will produce the same outcome. Switching to the VST3 version of the same plug and all works perfectly again.

I hope this is of some help.

Thank you once again for you kind offer of assistance.

Good :slight_smile: then remains maybe da goose’s case.

I think I found out the ‘problem’. It is indeed introduced since v9.5 but I think I know the reason.

In this case I have 2 files open, a 44k.1hz file already mastered and a 48khz to be mastered, both open in the same audio file tab.
The 44.1khz master is not passing through the bypass section with the help of the star icon (it’s a ref file).
The to be mastered 48khz is passing through, and in the mastersction are some plugins, but also the external gear plugin.
Pre 9.5 when you bypassed a file (star icon), it was never passed through the mastersection, but since 9.5 it still is even though it doesn’t playback the audio. I found out the with the same sample rate you can switch faster, so a plus (though I still don’t like it that it passes audio through my hardware which causes clipping because of the way to loud input = wear of tubes)
I suspect that because of the external gear plugin (so DA/AD through lynx hilo as well as monitoring) it needs to work harder to change the sample-rate.