Playing technique not playing back

I created an editorial trill [tr] and specified in the Edit playing technique dialog that the playback technique should be that of a trill. Upon playback, it doesn’t do anything. What else do I need to change?

You may need to specify it either as Trill (whole step) or Trill (half step) if you want it to play a particular sampled trill in your sound library of choice.

1 Like

I’ve tried it with Noteperformer and HSSE+HSO (pro) with regular trill, half-step and whole step. It doesn’t playback a trill. I’m attaching a short example…
EditorialTrillNoWork.dorico (1.1 MB)

The key words in Daniel’s post are “sampled trill.” NotePerformer doesn’t have sampled trills. If you change the playback template to HSSE+HSO (Pro) and change the playback technique for Editorial trill to Trill (half-step), both the flute and violin editorial trills can be heard. However, the trumpet doesn’t have sampled trills either.

  1. Create a Playback technique for your Editorial Trill
  2. Assign that playback technique to your Playing technique
  3. Add a switch to the expression map(s) of each instrument to trigger half/whole step trill with your new Playback Technique.

This works in HSSE+HSO(Pro) template, though I think you will need 2 versions of the editorial trill (one for half step and another for whole step trill).

I tend not to mess with the NotePerformer expression map as it has its own way of doing stuff!

As an alternative to worrying about sampled trills, you could add a real trill to each note with an editorial trill in your sample project and set the following properties for each real trill: Show trill mark and Has trill line without checking the boxes, Interval set to 2 Minor, and Appearance set to Accidental.

Thanks for all the ideas. I think what is confusing is that there is a Trill ornament that plays back in Dorico no matter the library (I think). In the edit playing techniques dialogs there is the option to specify the playback technique as trill. I thought that would do the same thing as the trill ornamentation and not require a sound library that had built in trills. It is confusing to me why it doesn’t do what a regular trill marking does.

I agree to some confusion. But I guess Dorico has to treat the trill marks differently from other playing techniques depending on whether it is generating the trill or using a library sample.

Could the issue be that the instrument already has an ongoing playing technique at the position of the trill, and therefore the playback techniques are in conflict? If so, you can set up a mutual exclusion group to make sure Dorico knows not to try to combine the techniques, and instead switch to the trill. Or, make sure the duration of the preceding playing technique stops before the trill so they don’t overlap.

No other techniques present so no playback conflicts. The solution I found was to put in a regular trill mark and hide it in the properties.

On further reflection, I suspect that Dorico is only looking at actual trill items in order to trigger trill playback, rather than looking for arbitrary playing technique items with the trill playback technique set. Sorry for the bum steer.