PLE change position in Frames to match actual frame rate.

When using PLE script as attached, unless the project frame rate is set to 25fps the selected event will not be moved exactly 1 frame, but instead it’s moved an uneven number corresponding to the length of 1/25 frame.
So in the case of a project running 50fps the selected event will be moved 2 frames instead of one. In other fps it will be moved an odd number.

To reproduce:

  • Create a PLE script as attached. (Property set to Event is Selected, Target set to Position adding 1 frame).
  • Select a different Project Frame Rate then 25.
  • Select an event and call the PLE script.
  • observe that it’s not being moved exactly 1 frame.

So I’ll more categorize it as a bug. It does have the correct value when using a PLE script that manipulates Length.

The same issue here!
Even setting project to 25fps does not guarantee precise event movement by frames. Just checked. In my case backward movement goes exactly by frames, but forward goes wrong - it moves 5 frames in 6 steps. Setting of 24 fps goes wrong in both directions. I didn’t check other fps setting of project.

v10.2.20 - Finally It workes now! At least for 25 fps.(I havn’t tried for 24 fps). I just had to remake my PLE preset and voila!

Interesting. They didn’t put anything in the change log for v10.2.20.
But to me 25fps always worked, so just hoping to get a fix for other frame rates :slight_smile:

I changed project settings to 24 fps, went to PLE,opened preset, changed frame to ppq and back again to 1 frame, saved preset with other name and then got proper 1 frame moving for 24fps. It turns out that frames in PLE and Logic editor are stored in other smaller values than frame. Definitely it’s a bug.
P.S. Just make different presets for different FPS, changing project settings before making it.