PLEASE - create a keycommand/function to RESET SNAP POINTS -UPDATED-

It happens all the time when editing small chunks of audio.

There is no quick way of resetting these snap points which affects all sorts of editing workflows, parameters and other basic commands like Quantize.

You can see the error in quantize

You can see me correcting snap points one at a time.





The only way to reset a snap point, is with the command ‘Snap Point To Cursor’, which does not work great when you have multiple events at different starting points.

This is a request that has been asked for years.

This drives me nuts. Cubase seems to move the snap points randomly at times, I’ll be working on a project and a random piece of audio will suddenly have its snap point changed. I’ve never been able to figure out why this happens, if it’s me, or literally just random. Catches me out all the time. I have zero use for moveable snap points personally, so I’d prefer a command that snaps the snap point back to the start of the event instantly without moving the cursor to the start of the event and then reseting.

It’s rare I get the situation you describe but it does happen.

For now, what if you select all the audio and type the start of them in the info bar?
My parts move randomly too. I learned to use Locking events as soon as I think I am done. But recently I learned that locking events not always lock everything such as voicing or chords if it following the chord track!

In this instance, I’ve discovered it is ARA2/Spectralayers causing it when an event isn’t perfectly on the grid/start of a bar.

But this can’t be the only cause, I’ve had this problem occur a lot way before ARA2 was invented. Maybe as far back as SX3.

I have hundreds of projects, song ideas, etc with this problem. It becomes apparent when opening up old projects, or importing tracks to project.

There is also the issue of, and another instance I believe this pops up, is if you are recording I think there is some sort of “smart” placement of the start point that isn’t always correct, and or, if you have a long record buffer in which you are lengthening the start of the recorded events to include buffer.

These creates SO MANY EDITING and EXPORT ERRORS - - - - PLEASE FIX THIS

I figured out what can cause this!

BOUNCING WITH THE RANGE TOOL

(As well as initiating ARA2)

+1

Thanks, this has been such an annoying quirk for so long!

Anyone know if this was improved in Version 11? This has been complained about since probably SX3.

We need a key command/function to RESET - - - ALL - - - SNAP POINTS SELECTED EVENTS.

I’ve discovered this also happens when exporting events and importing back into the project via ‘Create Audio Track’.

you can test this with a series of cycle markers guiding the export, if the cycle ranges are off the snap grid setting, it will add snap points automatically to the nearest grid line… sooooo annoying.