Please help me completely blow away all QC assignments

I recently made the mistake of trying the QC assignments in Cubase 12. It never really worked, but more to the point, I’ve found that ever since then, all the cc’s on my Arturia keylab are completely unusable. I’ve spend hours googling this issue, I’ve gone though all the midi stuff in Studio Setup and reset everything, I get the message “This will reset all port names and make all ports visible” etc… But it doesn’t change anything. Cubase completely ignores all CC data from that controller. I can see in MIDI Monitor that it’s sending midi CCs, and I can send CCs from that controller to all my other hosts. I just can’t do it in Cubase. So now I have to use cumbersome workarounds like create midi files in a different host and them import them into Cubase.

I finally just gave up and went into the user library and deleted the Cubase 12 prefs, but it turns out that only helped with new sessions. This midi controller curse seems to be attached to my current session. I think my next step will be to try creating a new session and then import all the tracks in from the session, pray that the midi curse doesn’t get imported with them, and then use a different DAW for future projects. But if someone could tell me if there’s any way to just completely nuke all this QC stuff for good, I’d be forever grateful.

Just an awful, awful experience.

Hi and welcome to the forum,

In the Studio > Studio Setup go thru all Remote Devices and set all MIDI Inputs to Not connected, please.

I appreciate your reply, but I’m afraid I’ve already tried that. As you can see in the screenshot, the inputs are already set to Not Connected. I don’t understand why Cubase doesn’t give you any way to delete these controls once you’ve created them. There’s no contextual menu when I right-click, nothing happens when I press the delete key, and nothing happens when I click Reset. It seems that once you’ve created them, you’re stuck with them forever.

Here’s the screenshot.

Is VST quick controls set to “Not Connected” too?

One other thing, you haven’t got a new MIDI Remote setup with focused quick controls mapped?

Yes, they’re both set to Not Connected. I’ve repeatedly opened the QC header in the instrument window and clicked “Remove all QC assignments” but it doesn’t help.

I finally managed to (sort of) fix the tainted session by doing the following:

  • Delete Cubase 12 prefs again, because it turned out that once I opened the tainted session, it seemed to also corrupt all new sessions I created after that.
  • Create a new Cubase session.
  • Go to Import Tracks From Session, and select all the tracks in my session.

After doing that, I am now able to use my midi controller again, but this new session is really messed up. Sends not working, automation problems, tracks that think they’re muted when they’re not… it will take hours just to get back to where I was before this whole debacle began. So if anyone has any other ideas about how to fix the original session, I’d sure appreciate it.

I shudder to imagine if something like this had happened in pro studio setting.

Have you checked the new MIDI Remote to ensure your controller hasn’t been automatically set up in there?

Cubase 12 comes with factory templates for some Arturia hardware that will automatically enable. It’s in the lower zone, MIDI Remote tab.

Hi,

Set all remote devices inputs to Not Connected, please. Including MIDI Remote and Chord Pads, please.