Please help me sort buffer issues AFTER increasing RAM


I only recently reached the limitations of having only 4gb of RAM on my laptop, so I purchased two more sticks and doubled it. At the time I was running the 32-bit version of Cubase, and started getting the slurring and crackling of playback…so I knew it was time to move up to 64-bit and increase the RAM.

Today I installed the 64-bit version on my laptop, also keeping the 32-bit one as well.

The problem comes when I enter “device setup” and I’m STILL seeing the same max settings as before. I use a Focusrite SAFFIRE 6 USB as my interface, and with the 32-bit version the buffer limit was always 1024. With the new install I would’ve expected that to increase to at LEAST 4 or 5gb.

Though I rarely use it nowadays, I also noticed that my ASIO4ALL driver is still maxed out at 2048.

What am I doing wrong? Is there another place in Cubase I should be adjusting buffer sizes? I double-checked the laptop (windows 7 64-bit) and can see that it “sees” the full 8gb.


RAM has nothing to do with your ASIO buffers.

Correct, RAM usually won’t help you with crackling, you need to either optimize your computer (turning off power saving features by using the steinberg audio power scheme normally has a good effect on performance), optimize your project (freezing or printing instruments and efx to audio), or upgrade your processor. Since you have a laptop, that more or less means buying a new computer. Alternatively, you could buy external dsp hardware to take load off your processor.

There are also differences between audio interfaces and corresponding drivers, some can increase the performance but I have a feeling that the focus is put on low latency/low buffer size when recording rather than high processing performance on high buffer sizes for mixing which I guess is your situation? (even though high quality gear probably helps in both cases)


I think you need to study your perception of what buffers are and their (non)relationship to ram usage is. I’m afraid you cannot do that via this forum reliably. Google search everything you think you need to know and then ask forums for details that you feel are technically obscure.

With your Saffire Pro driver your buffer size should be able to get very low 128 to give 5ms latency more or less for live input acceptable midi delay. High buffer sizes are not the target and if you are working the Saffire at 1024 then you need to go to the SAffire forum and check whether there are any driver problems running that high as recently new drivers for other soundcards like Emu have had issues there.
High buffers are used for playback when you expect to use heavy FX on many tracks (and you start getting the crackles)and low buffers for midi keyboard input.
More ram is not bad but may not have been needed. If you feel you have to spend money it’s best to ask on a forum before you spend it just to make sure you’re not putting yourself out of pocket before you need to or maybe need to spend more than you think.

If you look at my signature you will see system details. If you press the Windows key plus the pause button you will get your basic details. If you then enter them into your signature it helps other forum members to get a basic handle on any possible problems.

More RAM will let you get more sample data cached for instant access. It won’t make any difference to the processing power of your computer. If you were running out of power for running processor-hungry effects, you won’t see any difference.

Soundcard buffer sizes are tiny - a few KB per track. If you need lower latency, minimise them. If you’re running out of performance, raise them a bit. But you had room for all the buffers you could ever use in your 4GB :slight_smile:

Never mind. RAM is quite cheap these days. And more never does any harm.

I really appreciate the responses.

I ran the demo version of JBridge to bridge my 32-bit plugins to the 64-bit host, and still had the same stuttering/crackling issues. It’s not a matter of having lower latency, as I have pretty much finished recording the track…it’s down to simple playback. I can max out the buffer settings and it doesn’t appear to be enough.

I will keep tweaking, and keep everyone posted if I find a solution. thanks for the help…