Please help setup Cubase correctly!

Hi, guys!

I have some troubles with cubase settings. 5-7 tracks with 3-5 VST and 2-3 synths use almost all resources of PC. I understand, that hard configuration is important thing (my OS is Win 10, 64 bit, CPU - i5-2300, 4 cores, 2.8 MHz, 8Gb DDR3 RAM),

It’s no powerful system))

But how can I set Cubase’s Preferences correct?



Increase your Audio Device Buffer Size, please.

Thank you! But it. But it will affect the latency, and I can’t use my USB keyboard, Can anything be changed in the program settings?


You are right.

Those might help:

  • Optimise the Windows system
  • Increasing RAM
  • Audio Device with high-quality ASIO driver

You can also Freeze the other tracks, you are not working on, right now. Nothing more, this is physics. :wink:

1 Like

Are you using asio guard? This would help as well as using the steinberg power plan. What audio interface do you have and what do you have buffers set to?

If you have all o f the above already configured then rendering tracks may be your only option if you want to keep latency low. On my old computer I had to do this if I wanted to record drums from my Roland kit when the project was getting larger.

You could actually freeze the other instruments rather than render. You can the unfreeze later if you need to edit.

1 Like