Plug ins not licensed anymore

I lost Amped Elektra license after updating Windows 11.

It is still listed as registered but when I load Cubase 12 Pro,I have a message saying Licenses are missing or time limited licenses have expired.

I added this product through the Vouchers section on my Account as part of the 5 free plugins giveaway.

P.S. Do I need a Steinberg dongle to use Amped Elektra?

I’m Confused.

P.S. I tried reactivating Amped Elektra,Alto Glock ,and Electric Harmonis as these three fail to register in Cubase 12 pro.

I used the software elicensor to reactivate the plugins succesfully but they are still not registered in Cubase 12.

I think it was when I installed and activated Alto Glock and Electric Harmonics ,that those installs wrecked Amped Elektra but I have no idea how to get Amped elektra back.
In my product and LIbrary manager ,these plugins are registered and installed

I’m in a conundrum.

Is it the new Windows 11 update?

Do you have these licenses on the usb dongle or soft eLicenser? Can you see them when you run the eLicenser?

Try to open the eLicenser as administrator and let it run the maintenance.

It’s possible that eLicenser has generated a new soft licenser ID. Be sure to run the maintenance process when it opens.

Does it show in the eLicenser control panel? If not, you’ll need to go to mysteinberg account online and reactivate it to your new soft eLicenser ID. i.e.:

I tried that before and it did not work.
I will try again in the morning.

The elicenser software is very flaky on my Windows 11 machine.
It tells me use as administrator but when I do that,it does not show any plugins.

I am a bit worried about purchasing future libraries if this is what happens.

I think Steinberg should migrate all libraries to the download and library managers and rid the elicenser for good especially when it does not work in Windows 11.

Reinstall eLCC.

You must have done the Windows 11 update. The software locks the eLicenser when that happens. If you reinstall it should fix it.

Yes, eLCC is awful.

Steinberg must have fixed it on their side.

Elicensor worked in Admin mode and I cleaned up my plugins.


Everything working now.